%global _empty_manifest_terminate_build 0
Name: python-ampel-core
Version: 0.9.0
Release: 1
Summary: Alice in Modular Provenance-Enabled Land
License: BSD-3-Clause
URL: https://ampelproject.github.io
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0b/f1/c35d1b693bc5f9d4305d831b65aa8d828d304890beddb59d40c55dd960e7/ampel_core-0.9.0.tar.gz
BuildArch: noarch
Requires: python3-ampel-interface
Requires: python3-pymongo
Requires: python3-pydantic
Requires: python3-sjcl
Requires: python3-schedule
Requires: python3-yq
Requires: python3-prometheus-client
Requires: python3-xxhash
Requires: python3-psutil
Requires: python3-appdirs
Requires: python3-requests
Requires: python3-fastapi
Requires: python3-uvicorn[standard]
Requires: python3-Sphinx
Requires: python3-sphinx-press-theme
Requires: python3-sphinx-autodoc-typehints
Requires: python3-tomlkit
Requires: python3-slack-sdk
%description
# AMPEL-core
## Information about AMPEL is available [here](https://github.com/AmpelProject)
%package -n python3-ampel-core
Summary: Alice in Modular Provenance-Enabled Land
Provides: python-ampel-core
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ampel-core
# AMPEL-core
## Information about AMPEL is available [here](https://github.com/AmpelProject)
%package help
Summary: Development documents and examples for ampel-core
Provides: python3-ampel-core-doc
%description help
# AMPEL-core
## Information about AMPEL is available [here](https://github.com/AmpelProject)
%prep
%autosetup -n ampel-core-0.9.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ampel-core -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.9.0-1
- Package Spec generated