%global _empty_manifest_terminate_build 0
Name:		python-gravity
Version:	1.0.3
Release:	1
Summary:	Command-line utilities to assist in managing Galaxy servers
License:	MIT
URL:		https://github.com/galaxyproject/gravity
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e9/f4/e21d9b5a9053abde4b7d93ef66413e0322b04f7495d7ebb13b785682ce78/gravity-1.0.3.tar.gz
BuildArch:	noarch

Requires:	python3-Click
Requires:	python3-supervisor
Requires:	python3-pyyaml
Requires:	python3-packaging
Requires:	python3-pydantic
Requires:	python3-jsonref
Requires:	python3-requests
Requires:	python3-requests-unixsocket

%description
Modern Galaxy servers run multiple disparate processes: `gunicorn`_ for serving the web application, `celery`_ for
asynchronous tasks, `tusd`_ for fault-tolerant uploads, standalone Galaxy processes for job handling, and more. Gravity
is Galaxy's process manager, to make configuring and running these services simple.
Installing Gravity will give you two executables, ``galaxyctl`` which is used to manage the starting, stopping, and
logging of Galaxy's various processes, and ``galaxy``, which can be used to run a Galaxy server in the foreground.

%package -n python3-gravity
Summary:	Command-line utilities to assist in managing Galaxy servers
Provides:	python-gravity
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-gravity
Modern Galaxy servers run multiple disparate processes: `gunicorn`_ for serving the web application, `celery`_ for
asynchronous tasks, `tusd`_ for fault-tolerant uploads, standalone Galaxy processes for job handling, and more. Gravity
is Galaxy's process manager, to make configuring and running these services simple.
Installing Gravity will give you two executables, ``galaxyctl`` which is used to manage the starting, stopping, and
logging of Galaxy's various processes, and ``galaxy``, which can be used to run a Galaxy server in the foreground.

%package help
Summary:	Development documents and examples for gravity
Provides:	python3-gravity-doc
%description help
Modern Galaxy servers run multiple disparate processes: `gunicorn`_ for serving the web application, `celery`_ for
asynchronous tasks, `tusd`_ for fault-tolerant uploads, standalone Galaxy processes for job handling, and more. Gravity
is Galaxy's process manager, to make configuring and running these services simple.
Installing Gravity will give you two executables, ``galaxyctl`` which is used to manage the starting, stopping, and
logging of Galaxy's various processes, and ``galaxy``, which can be used to run a Galaxy server in the foreground.

%prep
%autosetup -n gravity-1.0.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-gravity -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.3-1
- Package Spec generated