%global _empty_manifest_terminate_build 0
Name: python-amset
Version: 0.4.18
Release: 1
Summary: AMSET is a tool to calculate carrier transport properties from ab initio calculation data
License: modified BSD
URL: https://github.com/hackingmaterials/amset
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/03/52/9d9d18c48591c27b8a406961bc5544ef6ecf7dd71955579b9ab9250772d3/amset-0.4.18.tar.gz
BuildArch: noarch
Requires: python3-pymatgen
Requires: python3-scipy
Requires: python3-monty
Requires: python3-matplotlib
Requires: python3-BoltzTraP2
Requires: python3-tqdm
Requires: python3-tabulate
Requires: python3-memory-profiler
Requires: python3-spglib
Requires: python3-click
Requires: python3-sumo
Requires: python3-h5py
Requires: python3-pyFFTW
Requires: python3-interpolation
Requires: python3-numba
Requires: python3-pawpyseed
Requires: python3-coverage
Requires: python3-codacy-coverage
Requires: python3-pycodestyle
Requires: python3-mypy
Requires: python3-pydocstyle
Requires: python3-flake8
Requires: python3-pylint
Requires: python3-black
Requires: python3-pre-commit
Requires: python3-mkdocs
Requires: python3-mkdocs-material
Requires: python3-mkdocs-minify-plugin
Requires: python3-mkdocs-macros-plugin
Requires: python3-markdown-include
Requires: python3-markdown-katex
Requires: python3-pytest
Requires: python3-pytest-cov
%description
#
AMSET is a package for calculating electronic transport properties from
first-principles calculations.
- **Website (including documentation):** https://hackingmaterials.lbl.gov/amset/
- **Help/Support:** https://discuss.matsci.org/c/amset
- **Source:** https://github.com/hackingmaterials/amset
If you find AMSET useful, please consider citing [our paper](https://www.nature.com/articles/s41467-021-22440-5):
```
Ganose, A. M., Park, J., Faghaninia, A., Woods-Robinson, R., Persson, K. A., Jain, A.
Efficient calculation of carrier scattering rates from first principles.
Nat. Commun. 12, 2222 (2021)
```
Interested in contributing? See our [contribution guidelines](https://github.com/hackingmaterials/amset/blob/main/CONTRIBUTING.md)
%package -n python3-amset
Summary: AMSET is a tool to calculate carrier transport properties from ab initio calculation data
Provides: python-amset
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-amset
#
AMSET is a package for calculating electronic transport properties from
first-principles calculations.
- **Website (including documentation):** https://hackingmaterials.lbl.gov/amset/
- **Help/Support:** https://discuss.matsci.org/c/amset
- **Source:** https://github.com/hackingmaterials/amset
If you find AMSET useful, please consider citing [our paper](https://www.nature.com/articles/s41467-021-22440-5):
```
Ganose, A. M., Park, J., Faghaninia, A., Woods-Robinson, R., Persson, K. A., Jain, A.
Efficient calculation of carrier scattering rates from first principles.
Nat. Commun. 12, 2222 (2021)
```
Interested in contributing? See our [contribution guidelines](https://github.com/hackingmaterials/amset/blob/main/CONTRIBUTING.md)
%package help
Summary: Development documents and examples for amset
Provides: python3-amset-doc
%description help
#
AMSET is a package for calculating electronic transport properties from
first-principles calculations.
- **Website (including documentation):** https://hackingmaterials.lbl.gov/amset/
- **Help/Support:** https://discuss.matsci.org/c/amset
- **Source:** https://github.com/hackingmaterials/amset
If you find AMSET useful, please consider citing [our paper](https://www.nature.com/articles/s41467-021-22440-5):
```
Ganose, A. M., Park, J., Faghaninia, A., Woods-Robinson, R., Persson, K. A., Jain, A.
Efficient calculation of carrier scattering rates from first principles.
Nat. Commun. 12, 2222 (2021)
```
Interested in contributing? See our [contribution guidelines](https://github.com/hackingmaterials/amset/blob/main/CONTRIBUTING.md)
%prep
%autosetup -n amset-0.4.18
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-amset -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.4.18-1
- Package Spec generated