%global _empty_manifest_terminate_build 0
Name:		python-sense-hat
Version:	2.4.0
Release:	1
Summary:	Python module to control the Raspberry Pi Sense HAT, originally used in the Astro Pi mission
License:	BSD
URL:		https://github.com/astro-pi/python-sense-hat
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/0d/fc/235ed624fffca17c155f4212e9348b5c0e5c3d8946745facf6dffc346ece/sense-hat-2.4.0.tar.gz
BuildArch:	noarch

Requires:	python3-pillow
Requires:	python3-numpy

%description
The Sense HAT features an 8x8 RGB LED matrix, a mini joystick and the following sensors:
* Gyroscope
* Accelerometer
* Magnetometer
* Temperature
* Humidity
* Barometric pressure

%package -n python3-sense-hat
Summary:	Python module to control the Raspberry Pi Sense HAT, originally used in the Astro Pi mission
Provides:	python-sense-hat
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sense-hat
The Sense HAT features an 8x8 RGB LED matrix, a mini joystick and the following sensors:
* Gyroscope
* Accelerometer
* Magnetometer
* Temperature
* Humidity
* Barometric pressure

%package help
Summary:	Development documents and examples for sense-hat
Provides:	python3-sense-hat-doc
%description help
The Sense HAT features an 8x8 RGB LED matrix, a mini joystick and the following sensors:
* Gyroscope
* Accelerometer
* Magnetometer
* Temperature
* Humidity
* Barometric pressure

%prep
%autosetup -n sense-hat-2.4.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sense-hat -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.0-1
- Package Spec generated