%global _empty_manifest_terminate_build 0
Name:		python-FLORIS
Version:	3.3
Release:	1
Summary:	A controls-oriented engineering wake model.
License:	Apache-2.0
URL:		https://github.com/NREL/FLORIS
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a8/3a/cb66fe3d950cf13836cb82a2a43368df4632c41cab5207b0bbc7da7a31ec/FLORIS-3.3.tar.gz
BuildArch:	noarch

Requires:	python3-attrs
Requires:	python3-pyyaml
Requires:	python3-numexpr
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-matplotlib
Requires:	python3-pandas
Requires:	python3-shapely
Requires:	python3-coloredlogs
Requires:	python3-pytest
Requires:	python3-isort
Requires:	python3-ruff
Requires:	python3-pre-commit
Requires:	python3-sphinx-autodoc-typehints
Requires:	python3-sphinx-book-theme
Requires:	python3-jupyter-book
Requires:	python3-sphinxcontrib-autoyaml

%description
A controls-oriented engineering wake model.


%package -n python3-FLORIS
Summary:	A controls-oriented engineering wake model.
Provides:	python-FLORIS
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-FLORIS
A controls-oriented engineering wake model.


%package help
Summary:	Development documents and examples for FLORIS
Provides:	python3-FLORIS-doc
%description help
A controls-oriented engineering wake model.


%prep
%autosetup -n FLORIS-3.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-FLORIS -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.3-1
- Package Spec generated