%global _empty_manifest_terminate_build 0
Name:		python-mastapy
Version:	12.0.3
Release:	1
Summary:	Python scripting API for Masta
License:	MIT License
URL:		https://www.smartmt.com/cae-software/masta/overview/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2e/e4/dadcb761c140a115d5aafd1ecd47484ad527de454d7397266cad8d85a0fc/mastapy-12.0.3.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-ptvsd
Requires:	python3-pythonnet
Requires:	python3-Pillow
Requires:	python3-packaging

%description
## mastapy

Mastapy is the Python scripting API for Masta.


%package -n python3-mastapy
Summary:	Python scripting API for Masta
Provides:	python-mastapy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-mastapy
## mastapy

Mastapy is the Python scripting API for Masta.


%package help
Summary:	Development documents and examples for mastapy
Provides:	python3-mastapy-doc
%description help
## mastapy

Mastapy is the Python scripting API for Masta.


%prep
%autosetup -n mastapy-12.0.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-mastapy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 12.0.3-1
- Package Spec generated