%global _empty_manifest_terminate_build 0
Name: python-mycotools
Version: 0.27.36
Release: 1
Summary: A compilation of bioinformatic and computation biology inspired python tools
License: GNU Lesser General Public License v3 or later (LGPLv3+)
URL: https://gitlab.com/xonq/mycotools/mycotools
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/97/9e/8fde0cbb9cedd95e9d1b89137708f36fc9ea8f5f631bf5485637c952305b/mycotools-0.27.36.tar.gz
BuildArch: noarch
Requires: python3-biopython
Requires: python3-pandas
Requires: python3-requests
Requires: python3-scipy
Requires: python3-openpyxl
Requires: python3-tqdm
%description
Now alpha support for prokaryotes too!
# NOTE
While extensive alpha testing has been conducted, this software is in a beta state, and errors are expected. Kindly report these issues and remain patient for fixes - if you can find the bug, even better! This software will have longterm maintenance, although my focus is on my own research.
Cheers,
Zachary Konkel
# PURPOSE
Bring broadscale comparative genomics to the masses.
Mycotools is a compilation of computational biology tools and database [MycotoolsDB](https://gitlab.com/xonq/mycotools/-/blob/master/mycotools/MTDB.md) software that facilitate large-scale prokaryote and fungal comparative genomics. MycotoolsDB locally assimilates all NCBI and MycoCosm (Joint Genome Institute) genomes into a database schema with uniform file curation, scalability, and automation as guiding principles.
- Installation is as simple as `updateDB.py --init `. No more limited and
incomplete databases.
- `updateDB.py --update` brings the database to the current date. No more
database obsolecence in the wake of accelerating genome availability.
- The MycotoolsDB (MTDB) uniformly curates the numerous notorious iterations of
the `gff`, allowing for reliable analyses and format expectations from
multiple eras.
- The `.mtdb` database format enables swift transitions from analyses with datasets of 100,000s genomes to as few as a lineage of interest. No more scrambling to acquire files for an analysis.
Mycotools is currently available as a beta subset of the full suite, excluding the database assimilation tools. MycotoolsDB is currently restricted to Ohio Supercomputer Center - if you are interested in early access, please email `konkelzach@protonmail.com`.
By integrating with the curated MycotoolsDB, Mycotools aids routine-complex tasks like retrieving `gff` or `fasta` accessions; running and compiling `fasta`s of MycotoolsDB BLAST/hmmsearches; biology-based database manipulation tools; automated phylogenetic analysis pipelines from blast to Pfam extraction to tree prediction, etc etc. Mycotools includes sets of utilities that also enable easy acquisition of batches of sequence data using `ncbiDwnld.py` and `jgiDwnld.py`.
# USAGE
Check out [README.md](https://gitlab.com/xonq/mycotools/-/tree/master/mycotools) for install and the [USAGE.md](https://gitlab.com/xonq/mycotools/-/blob/master/mycotools/USAGE.md) for a guide.
# CITING
If Mycotools contribute to your analysis, please cite this git repository (gitlab.com/xonq/mycotools) and mention the Mycotools version in line.
%package -n python3-mycotools
Summary: A compilation of bioinformatic and computation biology inspired python tools
Provides: python-mycotools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mycotools
Now alpha support for prokaryotes too!
# NOTE
While extensive alpha testing has been conducted, this software is in a beta state, and errors are expected. Kindly report these issues and remain patient for fixes - if you can find the bug, even better! This software will have longterm maintenance, although my focus is on my own research.
Cheers,
Zachary Konkel
# PURPOSE
Bring broadscale comparative genomics to the masses.
Mycotools is a compilation of computational biology tools and database [MycotoolsDB](https://gitlab.com/xonq/mycotools/-/blob/master/mycotools/MTDB.md) software that facilitate large-scale prokaryote and fungal comparative genomics. MycotoolsDB locally assimilates all NCBI and MycoCosm (Joint Genome Institute) genomes into a database schema with uniform file curation, scalability, and automation as guiding principles.
- Installation is as simple as `updateDB.py --init `. No more limited and
incomplete databases.
- `updateDB.py --update` brings the database to the current date. No more
database obsolecence in the wake of accelerating genome availability.
- The MycotoolsDB (MTDB) uniformly curates the numerous notorious iterations of
the `gff`, allowing for reliable analyses and format expectations from
multiple eras.
- The `.mtdb` database format enables swift transitions from analyses with datasets of 100,000s genomes to as few as a lineage of interest. No more scrambling to acquire files for an analysis.
Mycotools is currently available as a beta subset of the full suite, excluding the database assimilation tools. MycotoolsDB is currently restricted to Ohio Supercomputer Center - if you are interested in early access, please email `konkelzach@protonmail.com`.
By integrating with the curated MycotoolsDB, Mycotools aids routine-complex tasks like retrieving `gff` or `fasta` accessions; running and compiling `fasta`s of MycotoolsDB BLAST/hmmsearches; biology-based database manipulation tools; automated phylogenetic analysis pipelines from blast to Pfam extraction to tree prediction, etc etc. Mycotools includes sets of utilities that also enable easy acquisition of batches of sequence data using `ncbiDwnld.py` and `jgiDwnld.py`.
# USAGE
Check out [README.md](https://gitlab.com/xonq/mycotools/-/tree/master/mycotools) for install and the [USAGE.md](https://gitlab.com/xonq/mycotools/-/blob/master/mycotools/USAGE.md) for a guide.
# CITING
If Mycotools contribute to your analysis, please cite this git repository (gitlab.com/xonq/mycotools) and mention the Mycotools version in line.
%package help
Summary: Development documents and examples for mycotools
Provides: python3-mycotools-doc
%description help
Now alpha support for prokaryotes too!
# NOTE
While extensive alpha testing has been conducted, this software is in a beta state, and errors are expected. Kindly report these issues and remain patient for fixes - if you can find the bug, even better! This software will have longterm maintenance, although my focus is on my own research.
Cheers,
Zachary Konkel
# PURPOSE
Bring broadscale comparative genomics to the masses.
Mycotools is a compilation of computational biology tools and database [MycotoolsDB](https://gitlab.com/xonq/mycotools/-/blob/master/mycotools/MTDB.md) software that facilitate large-scale prokaryote and fungal comparative genomics. MycotoolsDB locally assimilates all NCBI and MycoCosm (Joint Genome Institute) genomes into a database schema with uniform file curation, scalability, and automation as guiding principles.
- Installation is as simple as `updateDB.py --init `. No more limited and
incomplete databases.
- `updateDB.py --update` brings the database to the current date. No more
database obsolecence in the wake of accelerating genome availability.
- The MycotoolsDB (MTDB) uniformly curates the numerous notorious iterations of
the `gff`, allowing for reliable analyses and format expectations from
multiple eras.
- The `.mtdb` database format enables swift transitions from analyses with datasets of 100,000s genomes to as few as a lineage of interest. No more scrambling to acquire files for an analysis.
Mycotools is currently available as a beta subset of the full suite, excluding the database assimilation tools. MycotoolsDB is currently restricted to Ohio Supercomputer Center - if you are interested in early access, please email `konkelzach@protonmail.com`.
By integrating with the curated MycotoolsDB, Mycotools aids routine-complex tasks like retrieving `gff` or `fasta` accessions; running and compiling `fasta`s of MycotoolsDB BLAST/hmmsearches; biology-based database manipulation tools; automated phylogenetic analysis pipelines from blast to Pfam extraction to tree prediction, etc etc. Mycotools includes sets of utilities that also enable easy acquisition of batches of sequence data using `ncbiDwnld.py` and `jgiDwnld.py`.
# USAGE
Check out [README.md](https://gitlab.com/xonq/mycotools/-/tree/master/mycotools) for install and the [USAGE.md](https://gitlab.com/xonq/mycotools/-/blob/master/mycotools/USAGE.md) for a guide.
# CITING
If Mycotools contribute to your analysis, please cite this git repository (gitlab.com/xonq/mycotools) and mention the Mycotools version in line.
%prep
%autosetup -n mycotools-0.27.36
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mycotools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.27.36-1
- Package Spec generated