%global _empty_manifest_terminate_build 0
Name: python-vos
Version: 3.4
Release: 1
Summary: CADC VOS Class Libraries
License: AGPLv3
URL: https://www.canfar.net/en/docs/storage
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/55/3b/342889a59663de2f70bc94bbcf1b53e3a8370fd4532494b1132d6cb10c07/vos-3.4.tar.gz
BuildArch: noarch
Requires: python3-html2text
Requires: python3-cadcutils
Requires: python3-aenum
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-flake8
Requires: python3-mock
%description
vos is a set of python modules and scripts that ease access to VOSpace.
The default installation of vos is tuned for accessing the VOSpace
provided by the `Canadian Advanced Network For Astronomical
Research `__ (CANFAR)
VOSpace is a Distributed Cloud storage service for use in Astronomy.
There are two ways to use vos:
1. access VOSpace using the command-line script: eg. *vcp*
2. use the vos module inside a Python script: ``import vos``
Authentication to the CANFAR VOSpace service is performed using X509
security certificates, header tokens or username/password pairs. The
authentication system is managed by the CADC Group Management Service
(GMS).
To retrieve an X509 security certificate for use with the ``vos`` tools
use the *cadc-get-cert* script included with this package.
Additional information is available in the `CANFAR
documentation `__
%package -n python3-vos
Summary: CADC VOS Class Libraries
Provides: python-vos
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-vos
vos is a set of python modules and scripts that ease access to VOSpace.
The default installation of vos is tuned for accessing the VOSpace
provided by the `Canadian Advanced Network For Astronomical
Research `__ (CANFAR)
VOSpace is a Distributed Cloud storage service for use in Astronomy.
There are two ways to use vos:
1. access VOSpace using the command-line script: eg. *vcp*
2. use the vos module inside a Python script: ``import vos``
Authentication to the CANFAR VOSpace service is performed using X509
security certificates, header tokens or username/password pairs. The
authentication system is managed by the CADC Group Management Service
(GMS).
To retrieve an X509 security certificate for use with the ``vos`` tools
use the *cadc-get-cert* script included with this package.
Additional information is available in the `CANFAR
documentation `__
%package help
Summary: Development documents and examples for vos
Provides: python3-vos-doc
%description help
vos is a set of python modules and scripts that ease access to VOSpace.
The default installation of vos is tuned for accessing the VOSpace
provided by the `Canadian Advanced Network For Astronomical
Research `__ (CANFAR)
VOSpace is a Distributed Cloud storage service for use in Astronomy.
There are two ways to use vos:
1. access VOSpace using the command-line script: eg. *vcp*
2. use the vos module inside a Python script: ``import vos``
Authentication to the CANFAR VOSpace service is performed using X509
security certificates, header tokens or username/password pairs. The
authentication system is managed by the CADC Group Management Service
(GMS).
To retrieve an X509 security certificate for use with the ``vos`` tools
use the *cadc-get-cert* script included with this package.
Additional information is available in the `CANFAR
documentation `__
%prep
%autosetup -n vos-3.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-vos -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 3.4-1
- Package Spec generated