%global _empty_manifest_terminate_build 0
Name:		python-Chibchas
Version:	0.2.13b0
Release:	1
Summary:	InstituLAC Automation Tools
License:	BSD
URL:		https://github.com/colav/Chibchas
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b2/7c/80d52cc260947d846a4abee0a46bc80df6544abbd0e3f6748b073d3249a6/Chibchas-0.2.13b0.tar.gz
BuildArch:	noarch

Requires:	python3-flask-wtf
Requires:	python3-wtforms
Requires:	python3-Flask-Bootstrap
Requires:	python3-html5lib
Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-helium
Requires:	python3-xlsxwriter
Requires:	python3-lxml
Requires:	python3-bs4
Requires:	python3-xlrd
Requires:	python3-openpyxl

%description
<center><img src="https://raw.githubusercontent.com/colav/colav.github.io/master/img/Logo.png"/></center>

# Chibchas
InstituLAC Automation Tools

# Description
Package allows to download data from InstituLAC/Minciencias (Colombia) and upload it to Google Drive to do validation

# Installation

## Package
`pip install chibchas`

# Usage
## Web app
Let's start the server executing
```.sh
chibchas_server
```
Or using some command line options
```.sh
chibchas_server --port 8080 --ip x.x.x.x
```

where `x.x.x.x` is your local IP

you can access to the server for the endpoints for example on: http://127.0.1.1:8080
depending on the IP and PORT that you are providing to `chibchas`.

## Console
To obtain the information of the first two groups and save the output files in `/home/usario/somedir` for InstituLAC official institution name `"UNIVERSIDAD DE ANTIOQUIA"`, use
```bash
chibchas_institulac --gdrive_path=/home/restrepo/tmp --institution="UNIVERSIDAD DE ANTIOQUIA" --end=2
```
or check `chibchas_institulac --help` for further options. The default `--end` option, save output files for all the avalaible "Avalados" groups.

The `--gdrive_path` can be a Google Drive folder. See below:

## Configure Google Drive Api
Create a project https://developers.google.com/workspace/guides/create-project

create a oauth credentials https://developers.google.com/drive/api/v3/enable-drive-api

download the json file with configuration
![JSON Api Config](img/apijson.png?raw=true "Download json with credentials")


## RClone
required administrative permissions with apt.

`apt install rclone`


configure rclone following [this instructions](https://rclone.org/drive/) 

client_id and client_secret can be found on the json previously downloaded.

Mount the filesystem, it doesn't required administrative permissions.

`
 rclone mount -v  --daemon remote:project/path  local/path
`


# License
BSD-3-Clause License 

# Links
http://colav.udea.edu.co/








%package -n python3-Chibchas
Summary:	InstituLAC Automation Tools
Provides:	python-Chibchas
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Chibchas
<center><img src="https://raw.githubusercontent.com/colav/colav.github.io/master/img/Logo.png"/></center>

# Chibchas
InstituLAC Automation Tools

# Description
Package allows to download data from InstituLAC/Minciencias (Colombia) and upload it to Google Drive to do validation

# Installation

## Package
`pip install chibchas`

# Usage
## Web app
Let's start the server executing
```.sh
chibchas_server
```
Or using some command line options
```.sh
chibchas_server --port 8080 --ip x.x.x.x
```

where `x.x.x.x` is your local IP

you can access to the server for the endpoints for example on: http://127.0.1.1:8080
depending on the IP and PORT that you are providing to `chibchas`.

## Console
To obtain the information of the first two groups and save the output files in `/home/usario/somedir` for InstituLAC official institution name `"UNIVERSIDAD DE ANTIOQUIA"`, use
```bash
chibchas_institulac --gdrive_path=/home/restrepo/tmp --institution="UNIVERSIDAD DE ANTIOQUIA" --end=2
```
or check `chibchas_institulac --help` for further options. The default `--end` option, save output files for all the avalaible "Avalados" groups.

The `--gdrive_path` can be a Google Drive folder. See below:

## Configure Google Drive Api
Create a project https://developers.google.com/workspace/guides/create-project

create a oauth credentials https://developers.google.com/drive/api/v3/enable-drive-api

download the json file with configuration
![JSON Api Config](img/apijson.png?raw=true "Download json with credentials")


## RClone
required administrative permissions with apt.

`apt install rclone`


configure rclone following [this instructions](https://rclone.org/drive/) 

client_id and client_secret can be found on the json previously downloaded.

Mount the filesystem, it doesn't required administrative permissions.

`
 rclone mount -v  --daemon remote:project/path  local/path
`


# License
BSD-3-Clause License 

# Links
http://colav.udea.edu.co/








%package help
Summary:	Development documents and examples for Chibchas
Provides:	python3-Chibchas-doc
%description help
<center><img src="https://raw.githubusercontent.com/colav/colav.github.io/master/img/Logo.png"/></center>

# Chibchas
InstituLAC Automation Tools

# Description
Package allows to download data from InstituLAC/Minciencias (Colombia) and upload it to Google Drive to do validation

# Installation

## Package
`pip install chibchas`

# Usage
## Web app
Let's start the server executing
```.sh
chibchas_server
```
Or using some command line options
```.sh
chibchas_server --port 8080 --ip x.x.x.x
```

where `x.x.x.x` is your local IP

you can access to the server for the endpoints for example on: http://127.0.1.1:8080
depending on the IP and PORT that you are providing to `chibchas`.

## Console
To obtain the information of the first two groups and save the output files in `/home/usario/somedir` for InstituLAC official institution name `"UNIVERSIDAD DE ANTIOQUIA"`, use
```bash
chibchas_institulac --gdrive_path=/home/restrepo/tmp --institution="UNIVERSIDAD DE ANTIOQUIA" --end=2
```
or check `chibchas_institulac --help` for further options. The default `--end` option, save output files for all the avalaible "Avalados" groups.

The `--gdrive_path` can be a Google Drive folder. See below:

## Configure Google Drive Api
Create a project https://developers.google.com/workspace/guides/create-project

create a oauth credentials https://developers.google.com/drive/api/v3/enable-drive-api

download the json file with configuration
![JSON Api Config](img/apijson.png?raw=true "Download json with credentials")


## RClone
required administrative permissions with apt.

`apt install rclone`


configure rclone following [this instructions](https://rclone.org/drive/) 

client_id and client_secret can be found on the json previously downloaded.

Mount the filesystem, it doesn't required administrative permissions.

`
 rclone mount -v  --daemon remote:project/path  local/path
`


# License
BSD-3-Clause License 

# Links
http://colav.udea.edu.co/








%prep
%autosetup -n Chibchas-0.2.13b0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Chibchas -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.13b0-1
- Package Spec generated