%global _empty_manifest_terminate_build 0
Name:		python-uqbar
Version:	0.6.9
Release:	1
Summary:	Tools for building documentation with Sphinx, Graphviz and LaTeX
License:	MIT
URL:		https://pypi.org/project/uqbar/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/72/f6/0826d9d8b856d7e809ca6f99977721f7fe3e80ca5cc8e47d5cad430e2781/uqbar-0.6.9.tar.gz
BuildArch:	noarch

Requires:	python3-Sphinx
Requires:	python3-Unidecode
Requires:	python3-black
Requires:	python3-sphinx-immaterial
Requires:	python3-flake8
Requires:	python3-isort
Requires:	python3-mypy
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-types-PyYAML
Requires:	python3-types-docutils

%description
# uqbar

[![](https://img.shields.io/pypi/pyversions/uqbar)]()
[![](https://img.shields.io/pypi/l/uqbar)]()
[![](https://img.shields.io/github/actions/workflow/status/josiah-wolf-oberholtzer/uqbar/test.yml?branch=main)]()

Tools for creating Sphinx and Graphviz documentation.


%package -n python3-uqbar
Summary:	Tools for building documentation with Sphinx, Graphviz and LaTeX
Provides:	python-uqbar
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-uqbar
# uqbar

[![](https://img.shields.io/pypi/pyversions/uqbar)]()
[![](https://img.shields.io/pypi/l/uqbar)]()
[![](https://img.shields.io/github/actions/workflow/status/josiah-wolf-oberholtzer/uqbar/test.yml?branch=main)]()

Tools for creating Sphinx and Graphviz documentation.


%package help
Summary:	Development documents and examples for uqbar
Provides:	python3-uqbar-doc
%description help
# uqbar

[![](https://img.shields.io/pypi/pyversions/uqbar)]()
[![](https://img.shields.io/pypi/l/uqbar)]()
[![](https://img.shields.io/github/actions/workflow/status/josiah-wolf-oberholtzer/uqbar/test.yml?branch=main)]()

Tools for creating Sphinx and Graphviz documentation.


%prep
%autosetup -n uqbar-0.6.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-uqbar -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.9-1
- Package Spec generated