%global _empty_manifest_terminate_build 0
Name:		python-seldom
Version:	3.2.2
Release:	1
Summary:	Seldom automation testing framework based on unittest.
License:	BSD
URL:		https://github.com/seldomQA/seldom/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/cc/cd/ccc72fc2c0d53185342fc9627e3083677f07d4d7409447d35f37ee46df24/seldom-3.2.2.tar.gz
BuildArch:	noarch

Requires:	python3-Appium-Python-Client
Requires:	python3-XTestRunner
Requires:	python3-parameterized
Requires:	python3-loguru
Requires:	python3-openpyxl
Requires:	python3-pyyaml
Requires:	python3-requests
Requires:	python3-jsonschema
Requires:	python3-jmespath
Requires:	python3-webdriver-manager
Requires:	python3-pymysql
Requires:	python3-genson
Requires:	python3-click
Requires:	python3-dateutil

%description
WebUI/HTTP automation testing framework based on unittest.

%package -n python3-seldom
Summary:	Seldom automation testing framework based on unittest.
Provides:	python-seldom
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-seldom
WebUI/HTTP automation testing framework based on unittest.

%package help
Summary:	Development documents and examples for seldom
Provides:	python3-seldom-doc
%description help
WebUI/HTTP automation testing framework based on unittest.

%prep
%autosetup -n seldom-3.2.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-seldom -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.2-1
- Package Spec generated