%global _empty_manifest_terminate_build 0
Name: python-isqlite
Version: 1.6.0
Release: 1
Summary: An improved Python interface to SQLite
License: MIT
URL: https://pypi.org/project/isqlite/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/66/b0/b24d1fe6bcf2bd032a91a5cc7b9174e82d09cf75160bdf6da2d540c0a182/isqlite-1.6.0.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-sqliteparser
Requires: python3-tabulate
%description
**WARNING: This project is no longer maintained. It is recommended that you use a proper ORM like [SQLAlchemy](https://www.sqlalchemy.org/) or [Django's ORM](https://docs.djangoproject.com/en/4.1/) instead.**
# isqlite
isqlite is an improved Python interface to SQLite. It has a more convenient API, support for schema diffing and migrations, and a command-line interface.
```python
from isqlite import Database
with Database(":memory:") as db:
pk = db.insert("employees", {"name": "John Doe", "age": 30})
person = db.get_by_pk("employees", pk)
print(person["name"], person["age"])
db.update_by_pk("employees", pk, {"age": 35})
employees = db.select(
"employees",
where="name LIKE :name_pattern AND age > 40",
values={"name_pattern": "John%"},
)
pairs = db.sql(
"""
SELECT
teams.name, employees.name
FROM
employees
INNER JOIN
teams
ON
employees.team = teams.id
"""
)
```
## Features
- A convenient Python API
- Database migrations with automatic schema diffing
- A command-line interface
## Installation
Install isqlite with Pip:
```shell
$ pip install isqlite
```
## Documentation
Comprehensive documentation, including an API reference, is available at .
## Version history
Version 1.0.0 of isqlite was released on October 17, 2021, after six months of development. isqlite adheres to [semantic versioning](https://semver.org/spec/v2.0.0.html), and detailed information about individual releases can be viewed in the [change log](/CHANGELOG.md).
%package -n python3-isqlite
Summary: An improved Python interface to SQLite
Provides: python-isqlite
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-isqlite
**WARNING: This project is no longer maintained. It is recommended that you use a proper ORM like [SQLAlchemy](https://www.sqlalchemy.org/) or [Django's ORM](https://docs.djangoproject.com/en/4.1/) instead.**
# isqlite
isqlite is an improved Python interface to SQLite. It has a more convenient API, support for schema diffing and migrations, and a command-line interface.
```python
from isqlite import Database
with Database(":memory:") as db:
pk = db.insert("employees", {"name": "John Doe", "age": 30})
person = db.get_by_pk("employees", pk)
print(person["name"], person["age"])
db.update_by_pk("employees", pk, {"age": 35})
employees = db.select(
"employees",
where="name LIKE :name_pattern AND age > 40",
values={"name_pattern": "John%"},
)
pairs = db.sql(
"""
SELECT
teams.name, employees.name
FROM
employees
INNER JOIN
teams
ON
employees.team = teams.id
"""
)
```
## Features
- A convenient Python API
- Database migrations with automatic schema diffing
- A command-line interface
## Installation
Install isqlite with Pip:
```shell
$ pip install isqlite
```
## Documentation
Comprehensive documentation, including an API reference, is available at .
## Version history
Version 1.0.0 of isqlite was released on October 17, 2021, after six months of development. isqlite adheres to [semantic versioning](https://semver.org/spec/v2.0.0.html), and detailed information about individual releases can be viewed in the [change log](/CHANGELOG.md).
%package help
Summary: Development documents and examples for isqlite
Provides: python3-isqlite-doc
%description help
**WARNING: This project is no longer maintained. It is recommended that you use a proper ORM like [SQLAlchemy](https://www.sqlalchemy.org/) or [Django's ORM](https://docs.djangoproject.com/en/4.1/) instead.**
# isqlite
isqlite is an improved Python interface to SQLite. It has a more convenient API, support for schema diffing and migrations, and a command-line interface.
```python
from isqlite import Database
with Database(":memory:") as db:
pk = db.insert("employees", {"name": "John Doe", "age": 30})
person = db.get_by_pk("employees", pk)
print(person["name"], person["age"])
db.update_by_pk("employees", pk, {"age": 35})
employees = db.select(
"employees",
where="name LIKE :name_pattern AND age > 40",
values={"name_pattern": "John%"},
)
pairs = db.sql(
"""
SELECT
teams.name, employees.name
FROM
employees
INNER JOIN
teams
ON
employees.team = teams.id
"""
)
```
## Features
- A convenient Python API
- Database migrations with automatic schema diffing
- A command-line interface
## Installation
Install isqlite with Pip:
```shell
$ pip install isqlite
```
## Documentation
Comprehensive documentation, including an API reference, is available at .
## Version history
Version 1.0.0 of isqlite was released on October 17, 2021, after six months of development. isqlite adheres to [semantic versioning](https://semver.org/spec/v2.0.0.html), and detailed information about individual releases can be viewed in the [change log](/CHANGELOG.md).
%prep
%autosetup -n isqlite-1.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-isqlite -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 1.6.0-1
- Package Spec generated