%global _empty_manifest_terminate_build 0 Name: python-AutoAiLib Version: 1.1.0 Release: 1 Summary: The library that automates the silly ML things. License: GNU GPLv3 URL: https://pypi.org/project/AutoAiLib/ Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3e/1d/a6e70d607be8e88b01f0f5986f731f4b09b656006f5e45f22ab4988c8311/AutoAiLib-1.1.0.tar.gz BuildArch: noarch %description

AutoAI

This repository is a compilation of scripts that I have created in my time working with machine learning. These scripts aim to automate the annoying and tedious parts of ML, allowing you to focus on what is important. PyPi: https://pypi.org/project/AutoAILib/
$ pip install autoailib
This library was developed for and used with keras convolutional neural networks. They do however work with other keras models, besides image test obviously.

AutoAiLib.general_tester(model path or object, labels, preprocessor)

Class Video Demo

AutoAiLib.general_tester.predict_single(example)

AutoAiLib.general_tester.predict_many(container=None, testing_folder = None, csv_dir)

AutoAi.convnet_tester(model path or object, labels)

Class Video Demo

AutoAi.image_predict(model_path, image_path, labels)

This function takes 3 arguments: a path to a keras model, a path to an image, and a list of labels.
Demo:
Given a the correct arguments, we get the following output, as well as this image saved to our model directory.

AutoAi.manual_test(model, testing_dir, labels)

This function tests a model given labels and testing data. It then compiles the results in a CSV file, and groups the results by class, and by correct and incorrect.
Example csv:

Update! This has now been packaged in the AutoAI.data_compiler class. AutoAi.data_compiler(self,src, dest, **kwargs)
AutoAi.data_compiler.run() will compile the data based on the constructor parameters.

This function takes 2 required arguments, an original data source file, and a path to the desired data directory. Given just these two arguments, this function will create a new testing data folder at dest with training, validation, and testing folders, containing folders for each class. You can alter the ratio with the ratio arguments, as well as provide a number of img transforms to do if you are using images.
Demo:
Given the a path to the following folder: If augmentation used the following results will be yielded: Then these images will be copied to the dest folder with copied file structure, but an added upper layer: Example showing the images made it:

Homeless Methods:

model_to_img(model_path)

plot(history=None, file=None, min_=0, max_=1)

%package -n python3-AutoAiLib Summary: The library that automates the silly ML things. Provides: python-AutoAiLib BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-AutoAiLib

AutoAI

This repository is a compilation of scripts that I have created in my time working with machine learning. These scripts aim to automate the annoying and tedious parts of ML, allowing you to focus on what is important. PyPi: https://pypi.org/project/AutoAILib/
$ pip install autoailib
This library was developed for and used with keras convolutional neural networks. They do however work with other keras models, besides image test obviously.

AutoAiLib.general_tester(model path or object, labels, preprocessor)

Class Video Demo

AutoAiLib.general_tester.predict_single(example)

AutoAiLib.general_tester.predict_many(container=None, testing_folder = None, csv_dir)

AutoAi.convnet_tester(model path or object, labels)

Class Video Demo

AutoAi.image_predict(model_path, image_path, labels)

This function takes 3 arguments: a path to a keras model, a path to an image, and a list of labels.
Demo:
Given a the correct arguments, we get the following output, as well as this image saved to our model directory.

AutoAi.manual_test(model, testing_dir, labels)

This function tests a model given labels and testing data. It then compiles the results in a CSV file, and groups the results by class, and by correct and incorrect.
Example csv:

Update! This has now been packaged in the AutoAI.data_compiler class. AutoAi.data_compiler(self,src, dest, **kwargs)
AutoAi.data_compiler.run() will compile the data based on the constructor parameters.

This function takes 2 required arguments, an original data source file, and a path to the desired data directory. Given just these two arguments, this function will create a new testing data folder at dest with training, validation, and testing folders, containing folders for each class. You can alter the ratio with the ratio arguments, as well as provide a number of img transforms to do if you are using images.
Demo:
Given the a path to the following folder: If augmentation used the following results will be yielded: Then these images will be copied to the dest folder with copied file structure, but an added upper layer: Example showing the images made it:

Homeless Methods:

model_to_img(model_path)

plot(history=None, file=None, min_=0, max_=1)

%package help Summary: Development documents and examples for AutoAiLib Provides: python3-AutoAiLib-doc %description help

AutoAI

This repository is a compilation of scripts that I have created in my time working with machine learning. These scripts aim to automate the annoying and tedious parts of ML, allowing you to focus on what is important. PyPi: https://pypi.org/project/AutoAILib/
$ pip install autoailib
This library was developed for and used with keras convolutional neural networks. They do however work with other keras models, besides image test obviously.

AutoAiLib.general_tester(model path or object, labels, preprocessor)

Class Video Demo

AutoAiLib.general_tester.predict_single(example)

AutoAiLib.general_tester.predict_many(container=None, testing_folder = None, csv_dir)

AutoAi.convnet_tester(model path or object, labels)

Class Video Demo

AutoAi.image_predict(model_path, image_path, labels)

This function takes 3 arguments: a path to a keras model, a path to an image, and a list of labels.
Demo:
Given a the correct arguments, we get the following output, as well as this image saved to our model directory.

AutoAi.manual_test(model, testing_dir, labels)

This function tests a model given labels and testing data. It then compiles the results in a CSV file, and groups the results by class, and by correct and incorrect.
Example csv:

Update! This has now been packaged in the AutoAI.data_compiler class. AutoAi.data_compiler(self,src, dest, **kwargs)
AutoAi.data_compiler.run() will compile the data based on the constructor parameters.

This function takes 2 required arguments, an original data source file, and a path to the desired data directory. Given just these two arguments, this function will create a new testing data folder at dest with training, validation, and testing folders, containing folders for each class. You can alter the ratio with the ratio arguments, as well as provide a number of img transforms to do if you are using images.
Demo:
Given the a path to the following folder: If augmentation used the following results will be yielded: Then these images will be copied to the dest folder with copied file structure, but an added upper layer: Example showing the images made it:

Homeless Methods:

model_to_img(model_path)

plot(history=None, file=None, min_=0, max_=1)

%prep %autosetup -n AutoAiLib-1.1.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-AutoAiLib -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Mon May 15 2023 Python_Bot - 1.1.0-1 - Package Spec generated