%global _empty_manifest_terminate_build 0
Name:		python-pymagnitude-lite
Version:	0.1.143
Release:	1
Summary:	Magnitude fork that only supports Word2Vec, GloVe and fastText embeddings
License:	MIT
URL:		https://github.com/neuml/magnitude
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/25/8a/0dea5276de4f0a8585c568d1811c2aa00bb9e4aee3c9b9c365d90984b839/pymagnitude-lite-0.1.143.tar.gz
BuildArch:	noarch

Requires:	python3-fasteners
Requires:	python3-lz4
Requires:	python3-numpy
Requires:	python3-xxhash

%description
# Magnitude fork that only supports Word2Vec, GloVe and fastText embeddings

This repository makes the following changes to the excellent Magnitude project: 

- Project simplified to only support Word2Vec, GloVe and fastText embeddings
- Approximate indexing/search methods removed
- Annoy, AllenNLP (ELMo) and Torch dependencies removed
- Removed internal SQLite related libraries (pysqlite, apsw) and use system SQLite package
- Removed logic to download and stream models. Models must all be locally available, remote servers will not be checked.
- Build process simplified to use PyPi dependencies

See Magnitude project for documentation and links to pre-trained models: https://github.com/plasticityai/magnitude




%package -n python3-pymagnitude-lite
Summary:	Magnitude fork that only supports Word2Vec, GloVe and fastText embeddings
Provides:	python-pymagnitude-lite
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pymagnitude-lite
# Magnitude fork that only supports Word2Vec, GloVe and fastText embeddings

This repository makes the following changes to the excellent Magnitude project: 

- Project simplified to only support Word2Vec, GloVe and fastText embeddings
- Approximate indexing/search methods removed
- Annoy, AllenNLP (ELMo) and Torch dependencies removed
- Removed internal SQLite related libraries (pysqlite, apsw) and use system SQLite package
- Removed logic to download and stream models. Models must all be locally available, remote servers will not be checked.
- Build process simplified to use PyPi dependencies

See Magnitude project for documentation and links to pre-trained models: https://github.com/plasticityai/magnitude




%package help
Summary:	Development documents and examples for pymagnitude-lite
Provides:	python3-pymagnitude-lite-doc
%description help
# Magnitude fork that only supports Word2Vec, GloVe and fastText embeddings

This repository makes the following changes to the excellent Magnitude project: 

- Project simplified to only support Word2Vec, GloVe and fastText embeddings
- Approximate indexing/search methods removed
- Annoy, AllenNLP (ELMo) and Torch dependencies removed
- Removed internal SQLite related libraries (pysqlite, apsw) and use system SQLite package
- Removed logic to download and stream models. Models must all be locally available, remote servers will not be checked.
- Build process simplified to use PyPi dependencies

See Magnitude project for documentation and links to pre-trained models: https://github.com/plasticityai/magnitude




%prep
%autosetup -n pymagnitude-lite-0.1.143

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pymagnitude-lite -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.143-1
- Package Spec generated