%global _empty_manifest_terminate_build 0
Name: python-pysyd
Version: 6.10.5
Release: 1
Summary: automated measurements of global asteroseismic parameters
License: MIT
URL: https://github.com/ashleychontos/pysyd
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a1/ca/7d0b0934ddfd29e208b46e59208edd808a18b6deb29affca8d786d13a6ca/pysyd-6.10.5.tar.gz
BuildArch: noarch
%description
## Documentation
The documentation for `pySYD` can be found [here](https://pysyd.readthedocs.io)
## Attribution
If you make use of `pySYD` in your work, please cite [Chontos et al. (2021)](https://arxiv.org/abs/2108.00582):
@ARTICLE{2021arXiv210800582C,
author = {{Chontos}, Ashley and {Huber}, Daniel and {Sayeed}, Maryum and {Yamsiri}, Pavadol},
title = "{$\texttt{pySYD}$: Automated measurements of global asteroseismic parameters}",
journal = {arXiv e-prints},
keywords = {Astrophysics - Solar and Stellar Astrophysics, Astrophysics - Instrumentation and Methods for Astrophysics},
year = 2021,
month = aug,
eid = {arXiv:2108.00582},
pages = {arXiv:2108.00582},
archivePrefix = {arXiv},
eprint = {2108.00582},
primaryClass = {astro-ph.SR},
adsurl = {https://ui.adsabs.harvard.edu/abs/2021arXiv210800582C},
adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
## License
© 2019-2022 Ashley Chontos and contributors.
`pySYD` is free software made available under the [MIT license](LICENSE.md).
## Contribution
Our [list](docs/AUTHORS.rst) of contributors continues to grow!
If you'd like to be a part of that, please see [our guide](CONTRIBUTING.md) for contributing.
%package -n python3-pysyd
Summary: automated measurements of global asteroseismic parameters
Provides: python-pysyd
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pysyd
## Documentation
The documentation for `pySYD` can be found [here](https://pysyd.readthedocs.io)
## Attribution
If you make use of `pySYD` in your work, please cite [Chontos et al. (2021)](https://arxiv.org/abs/2108.00582):
@ARTICLE{2021arXiv210800582C,
author = {{Chontos}, Ashley and {Huber}, Daniel and {Sayeed}, Maryum and {Yamsiri}, Pavadol},
title = "{$\texttt{pySYD}$: Automated measurements of global asteroseismic parameters}",
journal = {arXiv e-prints},
keywords = {Astrophysics - Solar and Stellar Astrophysics, Astrophysics - Instrumentation and Methods for Astrophysics},
year = 2021,
month = aug,
eid = {arXiv:2108.00582},
pages = {arXiv:2108.00582},
archivePrefix = {arXiv},
eprint = {2108.00582},
primaryClass = {astro-ph.SR},
adsurl = {https://ui.adsabs.harvard.edu/abs/2021arXiv210800582C},
adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
## License
© 2019-2022 Ashley Chontos and contributors.
`pySYD` is free software made available under the [MIT license](LICENSE.md).
## Contribution
Our [list](docs/AUTHORS.rst) of contributors continues to grow!
If you'd like to be a part of that, please see [our guide](CONTRIBUTING.md) for contributing.
%package help
Summary: Development documents and examples for pysyd
Provides: python3-pysyd-doc
%description help
## Documentation
The documentation for `pySYD` can be found [here](https://pysyd.readthedocs.io)
## Attribution
If you make use of `pySYD` in your work, please cite [Chontos et al. (2021)](https://arxiv.org/abs/2108.00582):
@ARTICLE{2021arXiv210800582C,
author = {{Chontos}, Ashley and {Huber}, Daniel and {Sayeed}, Maryum and {Yamsiri}, Pavadol},
title = "{$\texttt{pySYD}$: Automated measurements of global asteroseismic parameters}",
journal = {arXiv e-prints},
keywords = {Astrophysics - Solar and Stellar Astrophysics, Astrophysics - Instrumentation and Methods for Astrophysics},
year = 2021,
month = aug,
eid = {arXiv:2108.00582},
pages = {arXiv:2108.00582},
archivePrefix = {arXiv},
eprint = {2108.00582},
primaryClass = {astro-ph.SR},
adsurl = {https://ui.adsabs.harvard.edu/abs/2021arXiv210800582C},
adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
## License
© 2019-2022 Ashley Chontos and contributors.
`pySYD` is free software made available under the [MIT license](LICENSE.md).
## Contribution
Our [list](docs/AUTHORS.rst) of contributors continues to grow!
If you'd like to be a part of that, please see [our guide](CONTRIBUTING.md) for contributing.
%prep
%autosetup -n pysyd-6.10.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pysyd -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 6.10.5-1
- Package Spec generated