%global _empty_manifest_terminate_build 0
Name: python-cooler
Version: 0.9.1
Release: 1
Summary: Sparse binary format for genomic interaction matrices.
License: BSD-3-Clause
URL: https://pypi.org/project/cooler/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/80/65/96c623d5ee993ebd51d643bd877621161a3e6a0ebbca8029693311833633/cooler-0.9.1.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-pandas
Requires: python3-h5py
Requires: python3-click
Requires: python3-cytoolz
Requires: python3-multiprocess
Requires: python3-pyfaidx
Requires: python3-asciitree
Requires: python3-pyyaml
Requires: python3-simplejson
Requires: python3-biopython
Requires: python3-dask[array,dataframe]
Requires: python3-ipytree
Requires: python3-ipywidgets
Requires: python3-matplotlib
Requires: python3-pypairix
Requires: python3-psutil
Requires: python3-pysam
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-m2r
Requires: python3-numpydoc
Requires: python3-recommonmark
Requires: python3-coverage[toml]
Requires: python3-flake8
Requires: python3-flake8-pyproject
Requires: python3-isort
Requires: python3-pytest
Requires: python3-pytest-cov
%description
# Cooler
Latest Release |
|
License |
|
Build Status |
|
Pre-commit Status |
|
Docs Status |
|
Coverage |
|
Downloads |
|
Citation |
|
Community |
|
## A cool place to store your Hi-C
Cooler is a support library for a **sparse, compressed, binary** persistent storage [format](http://cooler.readthedocs.io/en/latest/schema.html), also called cooler, used to store genomic interaction data, such as Hi-C contact matrices.
The cooler file format is an implementation of a genomic matrix data model using [HDF5](https://en.wikipedia.org/wiki/Hierarchical_Data_Format) as the container format. The `cooler` package includes a suite of [command line tools](http://cooler.readthedocs.io/en/latest/cli.html) and a [Python API](http://cooler.readthedocs.io/en/latest/api.html) to facilitate creating, querying and manipulating cooler files.
To get started:
- [Install](#Installation) cooler
- Read the [documentation](http://cooler.readthedocs.org/en/stable/) and see the Jupyter Notebook [walkthrough](https://github.com/open2c/cooler-binder).
- _cool_ files from published Hi-C data sets are available at `ftp://cooler.csail.mit.edu/coolers`.
- Many more multires (_mcool_) files are available on the [4DN data portal](https://data.4dnucleome.org/visualization/index).
### Installation
Install from PyPI using pip.
```sh
$ pip install cooler
```
If you are using `conda`, you can alternatively install `cooler` from the [bioconda](https://bioconda.github.io/index.html) channel.
```sh
$ conda install -c conda-forge -c bioconda cooler
```
### Citing
Abdennur, N., and Mirny, L.A. (2020). Cooler: scalable storage for Hi-C data and other genomically labeled arrays. _Bioinformatics_. doi: [10.1093/bioinformatics/btz540](https://doi.org/10.1093/bioinformatics/btz540).
```bibtex
@article{cooler2020,
author = {Abdennur, Nezar and Mirny, Leonid A},
title = "{Cooler: scalable storage for Hi-C data and other genomically labeled arrays}",
journal={Bioinformatics},
volume={36},
number={1},
pages={311--316},
year={2020},
doi = {10.1093/bioinformatics/btz540},
url = {https://doi.org/10.1093/bioinformatics/btz540},
}
```
### Contributing
Interested in contributing to cooler? That's great! To get started, check out the [contributing guide](https://github.com/open2c/cooler/blob/master/CONTRIBUTING.md).
### Related projects
- Process Hi-C data with [distiller](https://github.com/open2c/distiller)!
- Downstream analysis with [cooltools](https://github.com/open2c/cooltools)!
- Visualize your cooler data with [HiGlass](http://higlass.io)!
%package -n python3-cooler
Summary: Sparse binary format for genomic interaction matrices.
Provides: python-cooler
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cooler
# Cooler
Latest Release |
|
License |
|
Build Status |
|
Pre-commit Status |
|
Docs Status |
|
Coverage |
|
Downloads |
|
Citation |
|
Community |
|
## A cool place to store your Hi-C
Cooler is a support library for a **sparse, compressed, binary** persistent storage [format](http://cooler.readthedocs.io/en/latest/schema.html), also called cooler, used to store genomic interaction data, such as Hi-C contact matrices.
The cooler file format is an implementation of a genomic matrix data model using [HDF5](https://en.wikipedia.org/wiki/Hierarchical_Data_Format) as the container format. The `cooler` package includes a suite of [command line tools](http://cooler.readthedocs.io/en/latest/cli.html) and a [Python API](http://cooler.readthedocs.io/en/latest/api.html) to facilitate creating, querying and manipulating cooler files.
To get started:
- [Install](#Installation) cooler
- Read the [documentation](http://cooler.readthedocs.org/en/stable/) and see the Jupyter Notebook [walkthrough](https://github.com/open2c/cooler-binder).
- _cool_ files from published Hi-C data sets are available at `ftp://cooler.csail.mit.edu/coolers`.
- Many more multires (_mcool_) files are available on the [4DN data portal](https://data.4dnucleome.org/visualization/index).
### Installation
Install from PyPI using pip.
```sh
$ pip install cooler
```
If you are using `conda`, you can alternatively install `cooler` from the [bioconda](https://bioconda.github.io/index.html) channel.
```sh
$ conda install -c conda-forge -c bioconda cooler
```
### Citing
Abdennur, N., and Mirny, L.A. (2020). Cooler: scalable storage for Hi-C data and other genomically labeled arrays. _Bioinformatics_. doi: [10.1093/bioinformatics/btz540](https://doi.org/10.1093/bioinformatics/btz540).
```bibtex
@article{cooler2020,
author = {Abdennur, Nezar and Mirny, Leonid A},
title = "{Cooler: scalable storage for Hi-C data and other genomically labeled arrays}",
journal={Bioinformatics},
volume={36},
number={1},
pages={311--316},
year={2020},
doi = {10.1093/bioinformatics/btz540},
url = {https://doi.org/10.1093/bioinformatics/btz540},
}
```
### Contributing
Interested in contributing to cooler? That's great! To get started, check out the [contributing guide](https://github.com/open2c/cooler/blob/master/CONTRIBUTING.md).
### Related projects
- Process Hi-C data with [distiller](https://github.com/open2c/distiller)!
- Downstream analysis with [cooltools](https://github.com/open2c/cooltools)!
- Visualize your cooler data with [HiGlass](http://higlass.io)!
%package help
Summary: Development documents and examples for cooler
Provides: python3-cooler-doc
%description help
# Cooler
Latest Release |
|
License |
|
Build Status |
|
Pre-commit Status |
|
Docs Status |
|
Coverage |
|
Downloads |
|
Citation |
|
Community |
|
## A cool place to store your Hi-C
Cooler is a support library for a **sparse, compressed, binary** persistent storage [format](http://cooler.readthedocs.io/en/latest/schema.html), also called cooler, used to store genomic interaction data, such as Hi-C contact matrices.
The cooler file format is an implementation of a genomic matrix data model using [HDF5](https://en.wikipedia.org/wiki/Hierarchical_Data_Format) as the container format. The `cooler` package includes a suite of [command line tools](http://cooler.readthedocs.io/en/latest/cli.html) and a [Python API](http://cooler.readthedocs.io/en/latest/api.html) to facilitate creating, querying and manipulating cooler files.
To get started:
- [Install](#Installation) cooler
- Read the [documentation](http://cooler.readthedocs.org/en/stable/) and see the Jupyter Notebook [walkthrough](https://github.com/open2c/cooler-binder).
- _cool_ files from published Hi-C data sets are available at `ftp://cooler.csail.mit.edu/coolers`.
- Many more multires (_mcool_) files are available on the [4DN data portal](https://data.4dnucleome.org/visualization/index).
### Installation
Install from PyPI using pip.
```sh
$ pip install cooler
```
If you are using `conda`, you can alternatively install `cooler` from the [bioconda](https://bioconda.github.io/index.html) channel.
```sh
$ conda install -c conda-forge -c bioconda cooler
```
### Citing
Abdennur, N., and Mirny, L.A. (2020). Cooler: scalable storage for Hi-C data and other genomically labeled arrays. _Bioinformatics_. doi: [10.1093/bioinformatics/btz540](https://doi.org/10.1093/bioinformatics/btz540).
```bibtex
@article{cooler2020,
author = {Abdennur, Nezar and Mirny, Leonid A},
title = "{Cooler: scalable storage for Hi-C data and other genomically labeled arrays}",
journal={Bioinformatics},
volume={36},
number={1},
pages={311--316},
year={2020},
doi = {10.1093/bioinformatics/btz540},
url = {https://doi.org/10.1093/bioinformatics/btz540},
}
```
### Contributing
Interested in contributing to cooler? That's great! To get started, check out the [contributing guide](https://github.com/open2c/cooler/blob/master/CONTRIBUTING.md).
### Related projects
- Process Hi-C data with [distiller](https://github.com/open2c/distiller)!
- Downstream analysis with [cooltools](https://github.com/open2c/cooltools)!
- Visualize your cooler data with [HiGlass](http://higlass.io)!
%prep
%autosetup -n cooler-0.9.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cooler -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.9.1-1
- Package Spec generated