%global _empty_manifest_terminate_build 0
Name: python-pycddlib
Version: 2.1.6
Release: 1
Summary: pycddlib is a Python wrapper for Komei Fukuda's cddlib.
License: GPL
URL: http://pypi.python.org/pypi/pycddlib
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/20/11/59591bda78ef5bb7635178f646e9ba9028883459bf32bbd123a4a9c533f6/pycddlib-2.1.6.tar.gz
%description
`cddlib `_ is
an implementation of the Double Description Method of Motzkin et
al. for generating all vertices (i.e. extreme points) and extreme rays
of a general convex polyhedron given by a system of linear
inequalities.
The program also supports the reverse operation (i.e. convex hull
computation). This means that one can move back and forth between an
inequality representation and a generator (i.e. vertex and ray)
representation of a polyhedron with cdd. Also, it can solve a linear
programming problem, i.e. a problem of maximizing and minimizing a
linear function over a polyhedron.
* Download: https://pypi.org/project/pycddlib/#files
* Documentation: https://pycddlib.readthedocs.io/en/latest/
* Development: https://github.com/mcmtroffaes/pycddlib/ |ci|
.. |ci| image:: https://github.com/mcmtroffaes/pycddlib/actions/workflows/python-package.yml/badge.svg
:target: https://github.com/mcmtroffaes/pycddlib/actions/workflows/python-package.yml
:alt: ci
%package -n python3-pycddlib
Summary: pycddlib is a Python wrapper for Komei Fukuda's cddlib.
Provides: python-pycddlib
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-pycddlib
`cddlib `_ is
an implementation of the Double Description Method of Motzkin et
al. for generating all vertices (i.e. extreme points) and extreme rays
of a general convex polyhedron given by a system of linear
inequalities.
The program also supports the reverse operation (i.e. convex hull
computation). This means that one can move back and forth between an
inequality representation and a generator (i.e. vertex and ray)
representation of a polyhedron with cdd. Also, it can solve a linear
programming problem, i.e. a problem of maximizing and minimizing a
linear function over a polyhedron.
* Download: https://pypi.org/project/pycddlib/#files
* Documentation: https://pycddlib.readthedocs.io/en/latest/
* Development: https://github.com/mcmtroffaes/pycddlib/ |ci|
.. |ci| image:: https://github.com/mcmtroffaes/pycddlib/actions/workflows/python-package.yml/badge.svg
:target: https://github.com/mcmtroffaes/pycddlib/actions/workflows/python-package.yml
:alt: ci
%package help
Summary: Development documents and examples for pycddlib
Provides: python3-pycddlib-doc
%description help
`cddlib `_ is
an implementation of the Double Description Method of Motzkin et
al. for generating all vertices (i.e. extreme points) and extreme rays
of a general convex polyhedron given by a system of linear
inequalities.
The program also supports the reverse operation (i.e. convex hull
computation). This means that one can move back and forth between an
inequality representation and a generator (i.e. vertex and ray)
representation of a polyhedron with cdd. Also, it can solve a linear
programming problem, i.e. a problem of maximizing and minimizing a
linear function over a polyhedron.
* Download: https://pypi.org/project/pycddlib/#files
* Documentation: https://pycddlib.readthedocs.io/en/latest/
* Development: https://github.com/mcmtroffaes/pycddlib/ |ci|
.. |ci| image:: https://github.com/mcmtroffaes/pycddlib/actions/workflows/python-package.yml/badge.svg
:target: https://github.com/mcmtroffaes/pycddlib/actions/workflows/python-package.yml
:alt: ci
%prep
%autosetup -n pycddlib-2.1.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pycddlib -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 2.1.6-1
- Package Spec generated