%global _empty_manifest_terminate_build 0
Name:		python-aiojenkins
Version:	0.7.8
Release:	1
Summary:	Asynchronous library of Jenkins API based on aiohttp
License:	MIT
URL:		https://github.com/pbelskiy/aiojenkins
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/24/3d/0e911e095f5af392f804e325eabdd43eac278a4b2a071aa1ac9466194568/aiojenkins-0.7.8.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp

%description
|Build status|
|Docs status|
|Coverage status|
|Version status|
|Downloads status|
   image:: https://github.com/pbelskiy/aiojenkins/workflows/Tests/badge.svg
   image:: https://readthedocs.org/projects/aiojenkins/badge/?version=latest
   image:: https://img.shields.io/coveralls/github/pbelskiy/aiojenkins?label=Coverage
   image:: https://img.shields.io/pypi/pyversions/aiojenkins?label=Python
   image:: https://img.shields.io/pypi/dm/aiojenkins?color=1&label=Downloads

%package -n python3-aiojenkins
Summary:	Asynchronous library of Jenkins API based on aiohttp
Provides:	python-aiojenkins
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-aiojenkins
|Build status|
|Docs status|
|Coverage status|
|Version status|
|Downloads status|
   image:: https://github.com/pbelskiy/aiojenkins/workflows/Tests/badge.svg
   image:: https://readthedocs.org/projects/aiojenkins/badge/?version=latest
   image:: https://img.shields.io/coveralls/github/pbelskiy/aiojenkins?label=Coverage
   image:: https://img.shields.io/pypi/pyversions/aiojenkins?label=Python
   image:: https://img.shields.io/pypi/dm/aiojenkins?color=1&label=Downloads

%package help
Summary:	Development documents and examples for aiojenkins
Provides:	python3-aiojenkins-doc
%description help
|Build status|
|Docs status|
|Coverage status|
|Version status|
|Downloads status|
   image:: https://github.com/pbelskiy/aiojenkins/workflows/Tests/badge.svg
   image:: https://readthedocs.org/projects/aiojenkins/badge/?version=latest
   image:: https://img.shields.io/coveralls/github/pbelskiy/aiojenkins?label=Coverage
   image:: https://img.shields.io/pypi/pyversions/aiojenkins?label=Python
   image:: https://img.shields.io/pypi/dm/aiojenkins?color=1&label=Downloads

%prep
%autosetup -n aiojenkins-0.7.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-aiojenkins -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.8-1
- Package Spec generated