%global _empty_manifest_terminate_build 0
Name: python-disnake-together
Version: 1.0.3
Release: 1
Summary: A 3rd party library to use discord's VC Party Games feature with disnake
License: MIT
URL: https://github.com/awesomehet2124/disnake_together
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4a/08/511fdd8cb83dd0c663724647167f84e449da846f2e6333efe93efb580527/disnake_together-1.0.3.tar.gz
BuildArch: noarch
%description
# disnake-together
## Table of Contents
- [About](#about)
- [Examples](#examples)
- [prerequisites](#prerequisites)
- [Contributing](#contributing)
## About
A 3rd party library for Discord's BETA feature of VC Party Games
### Prerequisites
You should have disnake installed in order to use this package
To install disnake, run the following code in a terminal
```
pip install disnake
```
### Examples
Generate a link for YouTube Together
```py
from disnake.ext import commands
from disnake_together import DisnakeTogether
client = commands.Bot(command_prefix = "*")
togetherControl = DisnakeTogether(client)
@client.command()
async def youtubeTogether(self, ctx):
togetherControl = DiscordTogether(self.client)
# To check if the user is in a vc
try:
vc = ctx.author.voice.channel.id
except:
await ctx.channel.send("You are not in a VC, please join one and then use the command")
# Get invite link
link = await togetherControl.create_link(vc, 'youtube')
await ctx.send(f"Click the link 👇\n{link}")
```
You can replace `youtube` with the other interactions i.e betrayal, chess, fishing, poker
### Contributing
- [LamerGamerYT](https://github.com/lamergameryt)
- [Bxllistic](https://github.com/apurv-r)
%package -n python3-disnake-together
Summary: A 3rd party library to use discord's VC Party Games feature with disnake
Provides: python-disnake-together
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-disnake-together
# disnake-together
## Table of Contents
- [About](#about)
- [Examples](#examples)
- [prerequisites](#prerequisites)
- [Contributing](#contributing)
## About
A 3rd party library for Discord's BETA feature of VC Party Games
### Prerequisites
You should have disnake installed in order to use this package
To install disnake, run the following code in a terminal
```
pip install disnake
```
### Examples
Generate a link for YouTube Together
```py
from disnake.ext import commands
from disnake_together import DisnakeTogether
client = commands.Bot(command_prefix = "*")
togetherControl = DisnakeTogether(client)
@client.command()
async def youtubeTogether(self, ctx):
togetherControl = DiscordTogether(self.client)
# To check if the user is in a vc
try:
vc = ctx.author.voice.channel.id
except:
await ctx.channel.send("You are not in a VC, please join one and then use the command")
# Get invite link
link = await togetherControl.create_link(vc, 'youtube')
await ctx.send(f"Click the link 👇\n{link}")
```
You can replace `youtube` with the other interactions i.e betrayal, chess, fishing, poker
### Contributing
- [LamerGamerYT](https://github.com/lamergameryt)
- [Bxllistic](https://github.com/apurv-r)
%package help
Summary: Development documents and examples for disnake-together
Provides: python3-disnake-together-doc
%description help
# disnake-together
## Table of Contents
- [About](#about)
- [Examples](#examples)
- [prerequisites](#prerequisites)
- [Contributing](#contributing)
## About
A 3rd party library for Discord's BETA feature of VC Party Games
### Prerequisites
You should have disnake installed in order to use this package
To install disnake, run the following code in a terminal
```
pip install disnake
```
### Examples
Generate a link for YouTube Together
```py
from disnake.ext import commands
from disnake_together import DisnakeTogether
client = commands.Bot(command_prefix = "*")
togetherControl = DisnakeTogether(client)
@client.command()
async def youtubeTogether(self, ctx):
togetherControl = DiscordTogether(self.client)
# To check if the user is in a vc
try:
vc = ctx.author.voice.channel.id
except:
await ctx.channel.send("You are not in a VC, please join one and then use the command")
# Get invite link
link = await togetherControl.create_link(vc, 'youtube')
await ctx.send(f"Click the link 👇\n{link}")
```
You can replace `youtube` with the other interactions i.e betrayal, chess, fishing, poker
### Contributing
- [LamerGamerYT](https://github.com/lamergameryt)
- [Bxllistic](https://github.com/apurv-r)
%prep
%autosetup -n disnake-together-1.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-disnake-together -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 1.0.3-1
- Package Spec generated