%global _empty_manifest_terminate_build 0
Name:		python-ConceptNet
Version:	5.7.0
Release:	1
Summary:	A semantic network of general knowledge
License:	Apache License 2.0
URL:		https://pypi.org/project/ConceptNet/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/7a/d4/8f53368a8c78d5daafe6ab1de3ec500cf22f440fc5d91a6b2c3a86512310/ConceptNet-5.7.0.tar.gz
BuildArch:	noarch


%description
ConceptNet aims to give computers access to common-sense knowledge, the kind of
information that ordinary people know but usually leave unstated.

This Python package contains a toolset for building the ConceptNet 5 knowledge
graph, possibly with your own custom data, and it serves the HTML interface and
JSON Web API for it.

You don't need this package to simply access ConceptNet 5; see
http://conceptnet.io for more information and a browsable Web interface with an
API.

Further documentation is available on the [ConceptNet wiki][].

Licensing and attribution appear in LICENSE.txt and DATA-CREDITS.md.


## Discussion groups

If you're interested in using ConceptNet, please join the conceptnet-users
Google group, for questions and occasional announcements:
http://groups.google.com/group/conceptnet-users?hl=en

For real-time discussion, ConceptNet also has a chat channel on Gitter:
https://gitter.im/commonsense/conceptnet5


## Installing and building ConceptNet

To be able to run all steps of the ConceptNet build process, you'll need a Unix
command line (Ubuntu 16.04 works great), Python 3.5 or later, 30 GB of RAM, and
some other dependencies. See the [build process][] on our wiki for instructions.

You may not need to build ConceptNet yourself! Try the [Web API][] first.

[build process]: https://github.com/commonsense/conceptnet5/wiki/Build-process
[Web API]: https://github.com/commonsense/conceptnet5/wiki/API
[ConceptNet wiki]: https://github.com/commonsense/conceptnet5/wiki

%package -n python3-ConceptNet
Summary:	A semantic network of general knowledge
Provides:	python-ConceptNet
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ConceptNet
ConceptNet aims to give computers access to common-sense knowledge, the kind of
information that ordinary people know but usually leave unstated.

This Python package contains a toolset for building the ConceptNet 5 knowledge
graph, possibly with your own custom data, and it serves the HTML interface and
JSON Web API for it.

You don't need this package to simply access ConceptNet 5; see
http://conceptnet.io for more information and a browsable Web interface with an
API.

Further documentation is available on the [ConceptNet wiki][].

Licensing and attribution appear in LICENSE.txt and DATA-CREDITS.md.


## Discussion groups

If you're interested in using ConceptNet, please join the conceptnet-users
Google group, for questions and occasional announcements:
http://groups.google.com/group/conceptnet-users?hl=en

For real-time discussion, ConceptNet also has a chat channel on Gitter:
https://gitter.im/commonsense/conceptnet5


## Installing and building ConceptNet

To be able to run all steps of the ConceptNet build process, you'll need a Unix
command line (Ubuntu 16.04 works great), Python 3.5 or later, 30 GB of RAM, and
some other dependencies. See the [build process][] on our wiki for instructions.

You may not need to build ConceptNet yourself! Try the [Web API][] first.

[build process]: https://github.com/commonsense/conceptnet5/wiki/Build-process
[Web API]: https://github.com/commonsense/conceptnet5/wiki/API
[ConceptNet wiki]: https://github.com/commonsense/conceptnet5/wiki

%package help
Summary:	Development documents and examples for ConceptNet
Provides:	python3-ConceptNet-doc
%description help
ConceptNet aims to give computers access to common-sense knowledge, the kind of
information that ordinary people know but usually leave unstated.

This Python package contains a toolset for building the ConceptNet 5 knowledge
graph, possibly with your own custom data, and it serves the HTML interface and
JSON Web API for it.

You don't need this package to simply access ConceptNet 5; see
http://conceptnet.io for more information and a browsable Web interface with an
API.

Further documentation is available on the [ConceptNet wiki][].

Licensing and attribution appear in LICENSE.txt and DATA-CREDITS.md.


## Discussion groups

If you're interested in using ConceptNet, please join the conceptnet-users
Google group, for questions and occasional announcements:
http://groups.google.com/group/conceptnet-users?hl=en

For real-time discussion, ConceptNet also has a chat channel on Gitter:
https://gitter.im/commonsense/conceptnet5


## Installing and building ConceptNet

To be able to run all steps of the ConceptNet build process, you'll need a Unix
command line (Ubuntu 16.04 works great), Python 3.5 or later, 30 GB of RAM, and
some other dependencies. See the [build process][] on our wiki for instructions.

You may not need to build ConceptNet yourself! Try the [Web API][] first.

[build process]: https://github.com/commonsense/conceptnet5/wiki/Build-process
[Web API]: https://github.com/commonsense/conceptnet5/wiki/API
[ConceptNet wiki]: https://github.com/commonsense/conceptnet5/wiki

%prep
%autosetup -n ConceptNet-5.7.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ConceptNet -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 5.7.0-1
- Package Spec generated