%global _empty_manifest_terminate_build 0
Name:		python-confluence-rest-library
Version:	1.2.2
Release:	1
Summary:	A simple wrapper around the Confluence REST API.
License:	MIT License
URL:		https://github.com/DaveTCode/confluence-python-lib
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/58/b9/b6b404fb25ed7b21a328dd1e0f8bebfc87c3d8373a50934789209708bf9f/confluence-rest-library-1.2.2.tar.gz
BuildArch:	noarch

Requires:	python3-requests

%description
This is a simple wrapper around the REST API which the Confluence
provides. Consider the API to be stable as of v1.0.0 (now released)
c.f. `endpoints.md`_ for a list of endpoints and whether this library
supports them yet. Please do send pull requests if you want an endpoint
that isn’t covered!

%package -n python3-confluence-rest-library
Summary:	A simple wrapper around the Confluence REST API.
Provides:	python-confluence-rest-library
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-confluence-rest-library
This is a simple wrapper around the REST API which the Confluence
provides. Consider the API to be stable as of v1.0.0 (now released)
c.f. `endpoints.md`_ for a list of endpoints and whether this library
supports them yet. Please do send pull requests if you want an endpoint
that isn’t covered!

%package help
Summary:	Development documents and examples for confluence-rest-library
Provides:	python3-confluence-rest-library-doc
%description help
This is a simple wrapper around the REST API which the Confluence
provides. Consider the API to be stable as of v1.0.0 (now released)
c.f. `endpoints.md`_ for a list of endpoints and whether this library
supports them yet. Please do send pull requests if you want an endpoint
that isn’t covered!

%prep
%autosetup -n confluence-rest-library-1.2.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-confluence-rest-library -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.2-1
- Package Spec generated