%global _empty_manifest_terminate_build 0
Name:		python-smltk
Version:	2.2.7
Release:	1
Summary:	Simple Machine Learning Tool Kit package
License:	MIT License
URL:		https://smltk.readthedocs.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d4/66/e99dee798400c280aae10e35c29d0a3ae7bdce1b5be32b42c92de12e1bd8/smltk-2.2.7.tar.gz
BuildArch:	noarch


%description
smltk (Simple Machine Learning Tool Kit) package is implemented for helping your work during
* data preparation
* testing your model
The goal is to implement this package for each step of machine learning process that can simplify your code.
It is part of the `educational repositories <https://github.com/pandle/materials>`_ to learn how to write stardard code and common uses of the TDD.
Installation
############
If you want to use this package into your code, you can install by python3-pip:
    pip3 install smltk
    python3
    >>> from smltk.metrics import Metrics
    >>> help(Metrics)
The package is not self-consistent. So if you want to contribute, you have to download the package by github and to install the requirements
    git clone https://github.com/bilardi/smltk
    cd smltk/
    pip3 install --upgrade -r requirements.txt
Read the documentation on `readthedocs <https://smltk.readthedocs.io/en/latest/>`_ for
* API
* Usage
* Development
Change Log
##########
See `CHANGELOG.md <https://github.com/bilardi/smltk/blob/master/CHANGELOG.md>`_ for details.
License
#######
This package is released under the MIT license.  See `LICENSE <https://github.com/bilardi/smltk/blob/master/LICENSE>`_ for details.

%package -n python3-smltk
Summary:	Simple Machine Learning Tool Kit package
Provides:	python-smltk
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-smltk
smltk (Simple Machine Learning Tool Kit) package is implemented for helping your work during
* data preparation
* testing your model
The goal is to implement this package for each step of machine learning process that can simplify your code.
It is part of the `educational repositories <https://github.com/pandle/materials>`_ to learn how to write stardard code and common uses of the TDD.
Installation
############
If you want to use this package into your code, you can install by python3-pip:
    pip3 install smltk
    python3
    >>> from smltk.metrics import Metrics
    >>> help(Metrics)
The package is not self-consistent. So if you want to contribute, you have to download the package by github and to install the requirements
    git clone https://github.com/bilardi/smltk
    cd smltk/
    pip3 install --upgrade -r requirements.txt
Read the documentation on `readthedocs <https://smltk.readthedocs.io/en/latest/>`_ for
* API
* Usage
* Development
Change Log
##########
See `CHANGELOG.md <https://github.com/bilardi/smltk/blob/master/CHANGELOG.md>`_ for details.
License
#######
This package is released under the MIT license.  See `LICENSE <https://github.com/bilardi/smltk/blob/master/LICENSE>`_ for details.

%package help
Summary:	Development documents and examples for smltk
Provides:	python3-smltk-doc
%description help
smltk (Simple Machine Learning Tool Kit) package is implemented for helping your work during
* data preparation
* testing your model
The goal is to implement this package for each step of machine learning process that can simplify your code.
It is part of the `educational repositories <https://github.com/pandle/materials>`_ to learn how to write stardard code and common uses of the TDD.
Installation
############
If you want to use this package into your code, you can install by python3-pip:
    pip3 install smltk
    python3
    >>> from smltk.metrics import Metrics
    >>> help(Metrics)
The package is not self-consistent. So if you want to contribute, you have to download the package by github and to install the requirements
    git clone https://github.com/bilardi/smltk
    cd smltk/
    pip3 install --upgrade -r requirements.txt
Read the documentation on `readthedocs <https://smltk.readthedocs.io/en/latest/>`_ for
* API
* Usage
* Development
Change Log
##########
See `CHANGELOG.md <https://github.com/bilardi/smltk/blob/master/CHANGELOG.md>`_ for details.
License
#######
This package is released under the MIT license.  See `LICENSE <https://github.com/bilardi/smltk/blob/master/LICENSE>`_ for details.

%prep
%autosetup -n smltk-2.2.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-smltk -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.7-1
- Package Spec generated