%global _empty_manifest_terminate_build 0
Name: python-hererocks
Version: 0.25.1
Release: 1
Summary: Tool for installing Lua and LuaRocks locally
License: MIT
URL: https://github.com/luarocks/hererocks
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/a0/9a9e8312da627ac39a5a719cadaf6b7f207856f7fc1c6461f3efd4dc690c/hererocks-0.25.1.tar.gz
BuildArch: noarch
%description
|gh-workflow| |codecov|
``hererocks`` is a single file Python 2.7/3.x script for installing `Lua `_
(or `LuaJIT `_ or `moonjit `_ or `RaptorJIT `_)
and `LuaRocks `_, its package manager, into a local directory.
It configures Lua to only see packages installed by that bundled version of LuaRocks, so that the installation is isolated.
%package -n python3-hererocks
Summary: Tool for installing Lua and LuaRocks locally
Provides: python-hererocks
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-hererocks
|gh-workflow| |codecov|
``hererocks`` is a single file Python 2.7/3.x script for installing `Lua `_
(or `LuaJIT `_ or `moonjit `_ or `RaptorJIT `_)
and `LuaRocks `_, its package manager, into a local directory.
It configures Lua to only see packages installed by that bundled version of LuaRocks, so that the installation is isolated.
%package help
Summary: Development documents and examples for hererocks
Provides: python3-hererocks-doc
%description help
|gh-workflow| |codecov|
``hererocks`` is a single file Python 2.7/3.x script for installing `Lua `_
(or `LuaJIT `_ or `moonjit `_ or `RaptorJIT `_)
and `LuaRocks `_, its package manager, into a local directory.
It configures Lua to only see packages installed by that bundled version of LuaRocks, so that the installation is isolated.
%prep
%autosetup -n hererocks-0.25.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-hererocks -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 29 2023 Python_Bot - 0.25.1-1
- Package Spec generated