%global _empty_manifest_terminate_build 0
Name:		python-acb-py
Version:	1.2.4
Release:	1
Summary:	Library for reading/extracting ACB files
License:	MIT License
URL:		https://github.com/summertriangle-dev/acb.py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b8/14/8925efbec812dbcd288729ce8f900e8d8422bc45682991f2d126b20362e5/acb-py-1.2.4.tar.gz


%description
## acb.py

For all your ACB extracting needs. Based on [VGMToolbox](https://sourceforge.net/projects/vgmtoolbox/).

HCA decryption is based on the 2ch HCA decoder. Thanks also to Headcrabbed who documented the new extra key [here](https://blog.mottomo.moe/categories/Tech/RE/en/2018-10-12-New-HCA-Encryption/).

Usage:

```sh
pip install acb-py
python3 -m acb somefile.acb output
# equivalent
acbextract somefile.acb output
```

You can also pass `--disarm-with=key1,key2` to have the library decrypt (but not decode) files for you. The key format
`--disarm-with=k1,k2` is equivalent to `hca_decoder -a k1 -b k2`, but you can also combine them into a 64-bit hex integer.
This also supports AWB embedded keys (see [here](https://github.com/hozuki/libcgss/issues/4)).
If you use disarm heavily, you should also install the `_acb_speedup` C extension in the `fast_sub`
directory. It will substantially speed up the decryption process.


%package -n python3-acb-py
Summary:	Library for reading/extracting ACB files
Provides:	python-acb-py
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-acb-py
## acb.py

For all your ACB extracting needs. Based on [VGMToolbox](https://sourceforge.net/projects/vgmtoolbox/).

HCA decryption is based on the 2ch HCA decoder. Thanks also to Headcrabbed who documented the new extra key [here](https://blog.mottomo.moe/categories/Tech/RE/en/2018-10-12-New-HCA-Encryption/).

Usage:

```sh
pip install acb-py
python3 -m acb somefile.acb output
# equivalent
acbextract somefile.acb output
```

You can also pass `--disarm-with=key1,key2` to have the library decrypt (but not decode) files for you. The key format
`--disarm-with=k1,k2` is equivalent to `hca_decoder -a k1 -b k2`, but you can also combine them into a 64-bit hex integer.
This also supports AWB embedded keys (see [here](https://github.com/hozuki/libcgss/issues/4)).
If you use disarm heavily, you should also install the `_acb_speedup` C extension in the `fast_sub`
directory. It will substantially speed up the decryption process.


%package help
Summary:	Development documents and examples for acb-py
Provides:	python3-acb-py-doc
%description help
## acb.py

For all your ACB extracting needs. Based on [VGMToolbox](https://sourceforge.net/projects/vgmtoolbox/).

HCA decryption is based on the 2ch HCA decoder. Thanks also to Headcrabbed who documented the new extra key [here](https://blog.mottomo.moe/categories/Tech/RE/en/2018-10-12-New-HCA-Encryption/).

Usage:

```sh
pip install acb-py
python3 -m acb somefile.acb output
# equivalent
acbextract somefile.acb output
```

You can also pass `--disarm-with=key1,key2` to have the library decrypt (but not decode) files for you. The key format
`--disarm-with=k1,k2` is equivalent to `hca_decoder -a k1 -b k2`, but you can also combine them into a 64-bit hex integer.
This also supports AWB embedded keys (see [here](https://github.com/hozuki/libcgss/issues/4)).
If you use disarm heavily, you should also install the `_acb_speedup` C extension in the `fast_sub`
directory. It will substantially speed up the decryption process.


%prep
%autosetup -n acb-py-1.2.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-acb-py -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.4-1
- Package Spec generated