%global _empty_manifest_terminate_build 0 Name: python-wxc Version: 7.1.0 Release: 1 Summary: A CLI facility to inspect Python environments. License: GPL-3.0 URL: https://github.com/neutrinoceros/wxc Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/1c/65712b160111398c3729b8e4f7a87a041770ce160f917a5ed16914e4f807/wxc-7.1.0.tar.gz BuildArch: noarch Requires: python3-rich Requires: python3-stdlib-list %description # wxc [![PyPI](https://img.shields.io/pypi/v/wxc.svg?logo=pypi&logoColor=white&label=PyPI)](https://pypi.org/project/wxc/) [![PyPI](https://img.shields.io/badge/requires-Python%20≥%203.7-blue?logo=python&logoColor=white)](https://pypi.org/project/wxc/) [![](https://img.shields.io/badge/contributions-welcome-brightgreen)](https://github.com/neutrinoceros/wxc/pulls) [![pre-commit.ci status](https://results.pre-commit.ci/badge/github/neutrinoceros/wxc/main.svg)](https://results.pre-commit.ci/latest/github/neutrinoceros/wxc/main) [![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black) [![Ruff](https://img.shields.io/endpoint?url=https://raw.githubusercontent.com/charliermarsh/ruff/main/assets/badge/v1.json)](https://github.com/charliermarsh/ruff) `wxc` (pronounced "which") allows you to inspect source code in your Python environment from the command line. It is based on the `inspect` module from the standard library. ## Installation ```shell $ python3 -m pip install wxc ``` ## Usage Get the version number of a package in your current environment

Locate the file from which a Python package is imported

Locate a specific method's source code

View the source code of function directly from the terminal stdout

`wxc` tries to be helpful when you mistype

For more, run ```shell $ wxc --help ``` ## Known limitations `wxc` is not currently able to retrieve the source of compiled code binded into Python. It should however correctly point to the compiled file that an object is imported from. `wxc` should never be installed in isolation (for instance via [pipx](https://pipxproject.github.io/pipx/)) since it would completely defeat its purpose. ## Notes - `wxc` is fully tested on macOS, Linux, and partially on Windows - this project was formerly named "whych" and renamed to avoid confusion with the pypi-available package of the same name. %package -n python3-wxc Summary: A CLI facility to inspect Python environments. Provides: python-wxc BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-wxc # wxc [![PyPI](https://img.shields.io/pypi/v/wxc.svg?logo=pypi&logoColor=white&label=PyPI)](https://pypi.org/project/wxc/) [![PyPI](https://img.shields.io/badge/requires-Python%20≥%203.7-blue?logo=python&logoColor=white)](https://pypi.org/project/wxc/) [![](https://img.shields.io/badge/contributions-welcome-brightgreen)](https://github.com/neutrinoceros/wxc/pulls) [![pre-commit.ci status](https://results.pre-commit.ci/badge/github/neutrinoceros/wxc/main.svg)](https://results.pre-commit.ci/latest/github/neutrinoceros/wxc/main) [![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black) [![Ruff](https://img.shields.io/endpoint?url=https://raw.githubusercontent.com/charliermarsh/ruff/main/assets/badge/v1.json)](https://github.com/charliermarsh/ruff) `wxc` (pronounced "which") allows you to inspect source code in your Python environment from the command line. It is based on the `inspect` module from the standard library. ## Installation ```shell $ python3 -m pip install wxc ``` ## Usage Get the version number of a package in your current environment

Locate the file from which a Python package is imported

Locate a specific method's source code

View the source code of function directly from the terminal stdout

`wxc` tries to be helpful when you mistype

For more, run ```shell $ wxc --help ``` ## Known limitations `wxc` is not currently able to retrieve the source of compiled code binded into Python. It should however correctly point to the compiled file that an object is imported from. `wxc` should never be installed in isolation (for instance via [pipx](https://pipxproject.github.io/pipx/)) since it would completely defeat its purpose. ## Notes - `wxc` is fully tested on macOS, Linux, and partially on Windows - this project was formerly named "whych" and renamed to avoid confusion with the pypi-available package of the same name. %package help Summary: Development documents and examples for wxc Provides: python3-wxc-doc %description help # wxc [![PyPI](https://img.shields.io/pypi/v/wxc.svg?logo=pypi&logoColor=white&label=PyPI)](https://pypi.org/project/wxc/) [![PyPI](https://img.shields.io/badge/requires-Python%20≥%203.7-blue?logo=python&logoColor=white)](https://pypi.org/project/wxc/) [![](https://img.shields.io/badge/contributions-welcome-brightgreen)](https://github.com/neutrinoceros/wxc/pulls) [![pre-commit.ci status](https://results.pre-commit.ci/badge/github/neutrinoceros/wxc/main.svg)](https://results.pre-commit.ci/latest/github/neutrinoceros/wxc/main) [![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black) [![Ruff](https://img.shields.io/endpoint?url=https://raw.githubusercontent.com/charliermarsh/ruff/main/assets/badge/v1.json)](https://github.com/charliermarsh/ruff) `wxc` (pronounced "which") allows you to inspect source code in your Python environment from the command line. It is based on the `inspect` module from the standard library. ## Installation ```shell $ python3 -m pip install wxc ``` ## Usage Get the version number of a package in your current environment

Locate the file from which a Python package is imported

Locate a specific method's source code

View the source code of function directly from the terminal stdout

`wxc` tries to be helpful when you mistype

For more, run ```shell $ wxc --help ``` ## Known limitations `wxc` is not currently able to retrieve the source of compiled code binded into Python. It should however correctly point to the compiled file that an object is imported from. `wxc` should never be installed in isolation (for instance via [pipx](https://pipxproject.github.io/pipx/)) since it would completely defeat its purpose. ## Notes - `wxc` is fully tested on macOS, Linux, and partially on Windows - this project was formerly named "whych" and renamed to avoid confusion with the pypi-available package of the same name. %prep %autosetup -n wxc-7.1.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-wxc -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Mon May 29 2023 Python_Bot - 7.1.0-1 - Package Spec generated