%global _empty_manifest_terminate_build 0
Name: python-george
Version: 0.4.0
Release: 1
Summary: Blazingly fast Gaussian Processes for regression.
License: MIT
URL: https://github.com/dfm/george
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/64/fd/d759543d18b1f94fd096845d9a9fca5ad583ddc3a9619f06d16162dbd1b1/george-0.4.0.tar.gz
Requires: python3-numpy
Requires: python3-scipy
%description
**Fast and flexible Gaussian Process regression in Python.**
Read the documentation at: `george.readthedocs.io `_.
%package -n python3-george
Summary: Blazingly fast Gaussian Processes for regression.
Provides: python-george
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-george
**Fast and flexible Gaussian Process regression in Python.**
Read the documentation at: `george.readthedocs.io `_.
%package help
Summary: Development documents and examples for george
Provides: python3-george-doc
%description help
**Fast and flexible Gaussian Process regression in Python.**
Read the documentation at: `george.readthedocs.io `_.
%prep
%autosetup -n george-0.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-george -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 29 2023 Python_Bot - 0.4.0-1
- Package Spec generated