%global _empty_manifest_terminate_build 0
Name:		python-algosec
Version:	1.3.5
Release:	1
Summary:	The AlgoSec SDK for Python
License:	MIT
URL:		https://github.com/algosec/algosec-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/23/10/3b4822fbef0fcf27bf1635054da7b98246f6c25e0228ae05829702f230ee/algosec-1.3.5.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-suds-jurko
Requires:	python3-suds-requests
Requires:	python3-ipaddress
Requires:	python3-six
Requires:	python3-deprecated

%description


%package -n python3-algosec
Summary:	The AlgoSec SDK for Python
Provides:	python-algosec
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-algosec


%package help
Summary:	Development documents and examples for algosec
Provides:	python3-algosec-doc
%description help


%prep
%autosetup -n algosec-1.3.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-algosec -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.5-1
- Package Spec generated