%global _empty_manifest_terminate_build 0
Name:		python-youtube2mp3
Version:	1.5.0
Release:	1
Summary:	Commandline tool to convert youtube videos to tagged mp3 files
License:	MIT
URL:		https://github.com/pfitzer/youtube2mp3.git
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/02/0c/37a921ccd5e5b1fca4b414fc638394542bc4e247c659816688347f4e37bc/youtube2mp3-1.5.0.tar.gz
BuildArch:	noarch

Requires:	python3-youtube-dl
Requires:	python3-mutagen

%description
A wrapper to simplify youtube downloads with `youtube-dl <https://youtube-dl.org/>`_
Downloaded files will be tagged with `mutagen <https://pypi.python.org/pypi/mutagen>`_.

%package -n python3-youtube2mp3
Summary:	Commandline tool to convert youtube videos to tagged mp3 files
Provides:	python-youtube2mp3
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-youtube2mp3
A wrapper to simplify youtube downloads with `youtube-dl <https://youtube-dl.org/>`_
Downloaded files will be tagged with `mutagen <https://pypi.python.org/pypi/mutagen>`_.

%package help
Summary:	Development documents and examples for youtube2mp3
Provides:	python3-youtube2mp3-doc
%description help
A wrapper to simplify youtube downloads with `youtube-dl <https://youtube-dl.org/>`_
Downloaded files will be tagged with `mutagen <https://pypi.python.org/pypi/mutagen>`_.

%prep
%autosetup -n youtube2mp3-1.5.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-youtube2mp3 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.0-1
- Package Spec generated