%global _empty_manifest_terminate_build 0 Name: python-pylj Version: 1.4.1 Release: 1 Summary: Simple teaching tool for classical MD simulation License: MIT URL: https://pypi.org/project/pylj/ Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4c/8f/c7ffefc271286685c04bb3faf8872f4636955c5de5bdcb66cb90bbe1a86f/pylj-1.4.1.tar.gz BuildArch: noarch Requires: python3-jupyter Requires: python3-numpy Requires: python3-matplotlib Requires: python3-cython Requires: python3-numba %description ## Visit the [pylj](http://pythoninchemistry.org/pylj) webpage for more information about pylj. To build from source: ```python pip install -r requirements.txt python setup.py build python setup.py install python setup.py test ``` Check out our publication in the [Journal of Open Source Education](http://jose.theoj.org/papers/58daa1a1a564dc8e0f99ffcdae20eb1d) to find out more about pylj. Be aware! pylj runs within a [Jupyter notebook](http://jupyter.org/), and therefore requires this to run. We advise installing [anaconda python](https://anaconda.org/) as this includes many required libraries as well as the Jupyter notebooks framework. If you need any help using pylj contact arm61 in the [pylj/HELP gitter chatroom](https://gitter.im/pylj/HELP). Check out some [examples](https://github.com/arm61/pylj/tree/master/examples) of how pylj can be used in undergraduate teaching exercises. ## Badges
JOSE DOI status
Latest Release PyPi version
DOI
Documentation Documentation Status
License License MIT
Build Status Build Status
Build Status
Coverage Status Coverage Status
Gitter Gitter chat
%package -n python3-pylj Summary: Simple teaching tool for classical MD simulation Provides: python-pylj BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-pylj ## Visit the [pylj](http://pythoninchemistry.org/pylj) webpage for more information about pylj. To build from source: ```python pip install -r requirements.txt python setup.py build python setup.py install python setup.py test ``` Check out our publication in the [Journal of Open Source Education](http://jose.theoj.org/papers/58daa1a1a564dc8e0f99ffcdae20eb1d) to find out more about pylj. Be aware! pylj runs within a [Jupyter notebook](http://jupyter.org/), and therefore requires this to run. We advise installing [anaconda python](https://anaconda.org/) as this includes many required libraries as well as the Jupyter notebooks framework. If you need any help using pylj contact arm61 in the [pylj/HELP gitter chatroom](https://gitter.im/pylj/HELP). Check out some [examples](https://github.com/arm61/pylj/tree/master/examples) of how pylj can be used in undergraduate teaching exercises. ## Badges
JOSE DOI status
Latest Release PyPi version
DOI
Documentation Documentation Status
License License MIT
Build Status Build Status
Build Status
Coverage Status Coverage Status
Gitter Gitter chat
%package help Summary: Development documents and examples for pylj Provides: python3-pylj-doc %description help ## Visit the [pylj](http://pythoninchemistry.org/pylj) webpage for more information about pylj. To build from source: ```python pip install -r requirements.txt python setup.py build python setup.py install python setup.py test ``` Check out our publication in the [Journal of Open Source Education](http://jose.theoj.org/papers/58daa1a1a564dc8e0f99ffcdae20eb1d) to find out more about pylj. Be aware! pylj runs within a [Jupyter notebook](http://jupyter.org/), and therefore requires this to run. We advise installing [anaconda python](https://anaconda.org/) as this includes many required libraries as well as the Jupyter notebooks framework. If you need any help using pylj contact arm61 in the [pylj/HELP gitter chatroom](https://gitter.im/pylj/HELP). Check out some [examples](https://github.com/arm61/pylj/tree/master/examples) of how pylj can be used in undergraduate teaching exercises. ## Badges
JOSE DOI status
Latest Release PyPi version
DOI
Documentation Documentation Status
License License MIT
Build Status Build Status
Build Status
Coverage Status Coverage Status
Gitter Gitter chat
%prep %autosetup -n pylj-1.4.1 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-pylj -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Mon May 29 2023 Python_Bot - 1.4.1-1 - Package Spec generated