%global _empty_manifest_terminate_build 0
Name: python-quote
Version: 2.0.4
Release: 1
Summary: A wrapper for the Goodreads Quote API
License: MIT License
URL: https://github.com/maxhumber/quote
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cf/a4/e67d5e79031014397eb53eda1757749f3ff30e81a6e8087571f3ce9e10b2/quote-2.0.4.tar.gz
BuildArch: noarch
%description
#### About
`quote` is a python wrapper for the Goodreads Quote API, powered by [gazpacho](https://github.com/maxhumber/gazpacho).
#### Quickstart
`quote` is simple to use:
```python
from quote import quote
search = 'Jasper Fforde'
result = quote(search, limit=2)
print(result)
# [{'author': 'Jasper Fforde',
# 'book': 'Something Rotten',
# 'quote': 'If the real world were a book, it would never find a publisher. Overlong, detailed to the point of distraction-and ultimately, without a major resolution.'},
# {'author': 'Jasper Fforde',
# 'book': 'The Well of Lost Plots',
# 'quote': "After all, reading is arguably a far more creative and imaginative process than writing; when the reader creates emotion in their head, or the colors of the sky during the setting sun, or the smell of a warm summer's breeze on their face, they should reserve as much praise for themselves as they do for the writer - perhaps more."}]
```
`quote` can also be used as a command line tool:
```sh
>>> max@mbp % quote 'alain de botton'
People only get really interesting when they start to rattle the bars of their cages.
>>> max@mbp % quote --search='alain de botton'
Intimacy is the capacity to be rather weird with someone - and finding that that's ok with them.
```
#### Install
```
pip install -U quote
```
#### Contribute
For feature requests or bug reports, please use [Github Issues](https://github.com/maxhumber/quote/issues)
%package -n python3-quote
Summary: A wrapper for the Goodreads Quote API
Provides: python-quote
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-quote
#### About
`quote` is a python wrapper for the Goodreads Quote API, powered by [gazpacho](https://github.com/maxhumber/gazpacho).
#### Quickstart
`quote` is simple to use:
```python
from quote import quote
search = 'Jasper Fforde'
result = quote(search, limit=2)
print(result)
# [{'author': 'Jasper Fforde',
# 'book': 'Something Rotten',
# 'quote': 'If the real world were a book, it would never find a publisher. Overlong, detailed to the point of distraction-and ultimately, without a major resolution.'},
# {'author': 'Jasper Fforde',
# 'book': 'The Well of Lost Plots',
# 'quote': "After all, reading is arguably a far more creative and imaginative process than writing; when the reader creates emotion in their head, or the colors of the sky during the setting sun, or the smell of a warm summer's breeze on their face, they should reserve as much praise for themselves as they do for the writer - perhaps more."}]
```
`quote` can also be used as a command line tool:
```sh
>>> max@mbp % quote 'alain de botton'
People only get really interesting when they start to rattle the bars of their cages.
>>> max@mbp % quote --search='alain de botton'
Intimacy is the capacity to be rather weird with someone - and finding that that's ok with them.
```
#### Install
```
pip install -U quote
```
#### Contribute
For feature requests or bug reports, please use [Github Issues](https://github.com/maxhumber/quote/issues)
%package help
Summary: Development documents and examples for quote
Provides: python3-quote-doc
%description help
#### About
`quote` is a python wrapper for the Goodreads Quote API, powered by [gazpacho](https://github.com/maxhumber/gazpacho).
#### Quickstart
`quote` is simple to use:
```python
from quote import quote
search = 'Jasper Fforde'
result = quote(search, limit=2)
print(result)
# [{'author': 'Jasper Fforde',
# 'book': 'Something Rotten',
# 'quote': 'If the real world were a book, it would never find a publisher. Overlong, detailed to the point of distraction-and ultimately, without a major resolution.'},
# {'author': 'Jasper Fforde',
# 'book': 'The Well of Lost Plots',
# 'quote': "After all, reading is arguably a far more creative and imaginative process than writing; when the reader creates emotion in their head, or the colors of the sky during the setting sun, or the smell of a warm summer's breeze on their face, they should reserve as much praise for themselves as they do for the writer - perhaps more."}]
```
`quote` can also be used as a command line tool:
```sh
>>> max@mbp % quote 'alain de botton'
People only get really interesting when they start to rattle the bars of their cages.
>>> max@mbp % quote --search='alain de botton'
Intimacy is the capacity to be rather weird with someone - and finding that that's ok with them.
```
#### Install
```
pip install -U quote
```
#### Contribute
For feature requests or bug reports, please use [Github Issues](https://github.com/maxhumber/quote/issues)
%prep
%autosetup -n quote-2.0.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-quote -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 29 2023 Python_Bot - 2.0.4-1
- Package Spec generated