%global _empty_manifest_terminate_build 0
Name: python-irisapi
Version: 1.0.37
Release: 1
Summary: Iris is a highly configurable and flexible service for paging and messaging.
License: BSD License
URL: https://github.com/linkedin/iris
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7f/c1/2e899767e64ce6945478e3241a51b177e3fb5d2131e87326f917a5c401db/irisapi-1.0.37.tar.gz
BuildArch: noarch
Requires: python3-streql
Requires: python3-dnspython
Requires: python3-phonenumbers
Requires: python3-twilio
Requires: python3-google-api-python-client
Requires: python3-oauth2client
Requires: python3-slackclient
Requires: python3-PyYAML
Requires: python3-greenlet
Requires: python3-gevent
Requires: python3-falcon
Requires: python3-falcon-cors
Requires: python3-ujson
Requires: python3-requests
Requires: python3-PyMySQL
Requires: python3-SQLAlchemy
Requires: python3-Jinja2
Requires: python3-Markdown
Requires: python3-click
Requires: python3-msgpack
Requires: python3-cssmin
Requires: python3-beaker
Requires: python3-cryptography
Requires: python3-webassets
Requires: python3-ldap
Requires: python3-exchangelib
Requires: python3-setproctitle
Requires: python3-pyfcm
Requires: python3-oncallclient
Requires: python3-idna
Requires: python3-pyqrcode
Requires: python3-gunicorn
Requires: python3-Sphinx
Requires: python3-sphinxcontrib-httpdomain
Requires: python3-sphinx-rtd-theme
Requires: python3-mock
Requires: python3-pytest
Requires: python3-pytest-mock
Requires: python3-pytest-cov
Requires: python3-flake8
Requires: python3-tox
Requires: python3-requests-mock
Requires: python3-influxdb
Requires: python3-kazoo
Requires: python3-prometheus-client
%description
Iris core, API, UI and sender service. For third-party integration support, see [iris-relay](https://github.com/linkedin/iris-relay), a stateless proxy designed to sit at the edge of a production network and allow external traffic to pass through. We also have an Iris mobile app for iOS/Android, at the [iris-mobile](https://github.com/linkedin/iris-mobile) repo.
![](https://github.com/linkedin/iris/raw/master/docs/source/_static/demo.png)
%package -n python3-irisapi
Summary: Iris is a highly configurable and flexible service for paging and messaging.
Provides: python-irisapi
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-irisapi
Iris core, API, UI and sender service. For third-party integration support, see [iris-relay](https://github.com/linkedin/iris-relay), a stateless proxy designed to sit at the edge of a production network and allow external traffic to pass through. We also have an Iris mobile app for iOS/Android, at the [iris-mobile](https://github.com/linkedin/iris-mobile) repo.
![](https://github.com/linkedin/iris/raw/master/docs/source/_static/demo.png)
%package help
Summary: Development documents and examples for irisapi
Provides: python3-irisapi-doc
%description help
Iris core, API, UI and sender service. For third-party integration support, see [iris-relay](https://github.com/linkedin/iris-relay), a stateless proxy designed to sit at the edge of a production network and allow external traffic to pass through. We also have an Iris mobile app for iOS/Android, at the [iris-mobile](https://github.com/linkedin/iris-mobile) repo.
![](https://github.com/linkedin/iris/raw/master/docs/source/_static/demo.png)
%prep
%autosetup -n irisapi-1.0.37
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-irisapi -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 29 2023 Python_Bot - 1.0.37-1
- Package Spec generated