%global _empty_manifest_terminate_build 0
Name: python-sense2vec
Version: 2.0.2
Release: 1
Summary: Contextually-keyed word vectors
License: MIT
URL: https://github.com/explosion/sense2vec
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ad/e3/e987ff210e1882cc6d6d8196ef9314474d5be9ef0f5714e37470c41a0383/sense2vec-2.0.2.tar.gz
BuildArch: noarch
Requires: python3-spacy
Requires: python3-wasabi
Requires: python3-srsly
Requires: python3-catalogue
Requires: python3-numpy
Requires: python3-importlib-metadata
%description
### class `Sense2VecComponent`
The pipeline component to add sense2vec to spaCy pipelines.
#### method `Sense2VecComponent.__init__`
Initialize the pipeline component.
| Argument | Type | Description |
| --------------- | --------------------------------------------------------------------------------------------------------------------- | ----------------------------------------------------------------------------------------------------------- |
| `vocab` | `Vocab` | The shared `Vocab`. Mostly used for the shared `StringStore`. |
| `shape` | tuple | The vector shape. |
| `merge_phrases` | bool | Whether to merge sense2vec phrases into one token. Defaults to `False`. |
| `lemmatize` | bool | Always look up lemmas if available in the vectors, otherwise default to original word. Defaults to `False`. |
| `overrides` | Optional custom functions to use, mapped to names registred via the registry, e.g. `{"make_key": "custom_make_key"}`. |
| **RETURNS** | `Sense2VecComponent` | The newly constructed object. |
```python
s2v = Sense2VecComponent(nlp.vocab)
```
#### classmethod `Sense2VecComponent.from_nlp`
Initialize the component from an nlp object. Mostly used as the component
factory for the entry point (see setup.cfg) and to auto-register via the
`@spacy.component` decorator.
| Argument | Type | Description |
| ----------- | -------------------- | ----------------------------- |
| `nlp` | `Language` | The `nlp` object. |
| `**cfg` | - | Optional config parameters. |
| **RETURNS** | `Sense2VecComponent` | The newly constructed object. |
```python
s2v = Sense2VecComponent.from_nlp(nlp)
```
#### method `Sense2VecComponent.__call__`
Process a `Doc` object with the component. Typically only called as part of the
spaCy pipeline and not directly.
| Argument | Type | Description |
| ----------- | ----- | ------------------------ |
| `doc` | `Doc` | The document to process. |
| **RETURNS** | `Doc` | the processed document. |
#### method `Sense2Vec.init_component`
Register the component-specific extension attributes here and only if the
component is added to the pipeline and used – otherwise, tokens will still get
the attributes even if the component is only created and not added.
#### method `Sense2VecComponent.to_bytes`
Serialize the component to a bytestring. Also called when the component is added
to the pipeline and you run `nlp.to_bytes`.
| Argument | Type | Description |
| ----------- | ----- | ------------------------- |
| **RETURNS** | bytes | The serialized component. |
#### method `Sense2VecComponent.from_bytes`
Load a component from a bytestring. Also called when you run `nlp.from_bytes`.
| Argument | Type | Description |
| ------------ | -------------------- | ------------------ |
| `bytes_data` | bytes | The data to load. |
| **RETURNS** | `Sense2VecComponent` | The loaded object. |
#### method `Sense2VecComponent.to_disk`
Serialize the component to a directory. Also called when the component is added
to the pipeline and you run `nlp.to_disk`.
| Argument | Type | Description |
| -------- | ---------------- | ----------- |
| `path` | unicode / `Path` | The path. |
#### method `Sense2VecComponent.from_disk`
Load a `Sense2Vec` object from a directory. Also called when you run
`nlp.from_disk`.
| Argument | Type | Description |
| ----------- | -------------------- | --------------------- |
| `path` | unicode / `Path` | The path to load from |
%package -n python3-sense2vec
Summary: Contextually-keyed word vectors
Provides: python-sense2vec
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sense2vec
### class `Sense2VecComponent`
The pipeline component to add sense2vec to spaCy pipelines.
#### method `Sense2VecComponent.__init__`
Initialize the pipeline component.
| Argument | Type | Description |
| --------------- | --------------------------------------------------------------------------------------------------------------------- | ----------------------------------------------------------------------------------------------------------- |
| `vocab` | `Vocab` | The shared `Vocab`. Mostly used for the shared `StringStore`. |
| `shape` | tuple | The vector shape. |
| `merge_phrases` | bool | Whether to merge sense2vec phrases into one token. Defaults to `False`. |
| `lemmatize` | bool | Always look up lemmas if available in the vectors, otherwise default to original word. Defaults to `False`. |
| `overrides` | Optional custom functions to use, mapped to names registred via the registry, e.g. `{"make_key": "custom_make_key"}`. |
| **RETURNS** | `Sense2VecComponent` | The newly constructed object. |
```python
s2v = Sense2VecComponent(nlp.vocab)
```
#### classmethod `Sense2VecComponent.from_nlp`
Initialize the component from an nlp object. Mostly used as the component
factory for the entry point (see setup.cfg) and to auto-register via the
`@spacy.component` decorator.
| Argument | Type | Description |
| ----------- | -------------------- | ----------------------------- |
| `nlp` | `Language` | The `nlp` object. |
| `**cfg` | - | Optional config parameters. |
| **RETURNS** | `Sense2VecComponent` | The newly constructed object. |
```python
s2v = Sense2VecComponent.from_nlp(nlp)
```
#### method `Sense2VecComponent.__call__`
Process a `Doc` object with the component. Typically only called as part of the
spaCy pipeline and not directly.
| Argument | Type | Description |
| ----------- | ----- | ------------------------ |
| `doc` | `Doc` | The document to process. |
| **RETURNS** | `Doc` | the processed document. |
#### method `Sense2Vec.init_component`
Register the component-specific extension attributes here and only if the
component is added to the pipeline and used – otherwise, tokens will still get
the attributes even if the component is only created and not added.
#### method `Sense2VecComponent.to_bytes`
Serialize the component to a bytestring. Also called when the component is added
to the pipeline and you run `nlp.to_bytes`.
| Argument | Type | Description |
| ----------- | ----- | ------------------------- |
| **RETURNS** | bytes | The serialized component. |
#### method `Sense2VecComponent.from_bytes`
Load a component from a bytestring. Also called when you run `nlp.from_bytes`.
| Argument | Type | Description |
| ------------ | -------------------- | ------------------ |
| `bytes_data` | bytes | The data to load. |
| **RETURNS** | `Sense2VecComponent` | The loaded object. |
#### method `Sense2VecComponent.to_disk`
Serialize the component to a directory. Also called when the component is added
to the pipeline and you run `nlp.to_disk`.
| Argument | Type | Description |
| -------- | ---------------- | ----------- |
| `path` | unicode / `Path` | The path. |
#### method `Sense2VecComponent.from_disk`
Load a `Sense2Vec` object from a directory. Also called when you run
`nlp.from_disk`.
| Argument | Type | Description |
| ----------- | -------------------- | --------------------- |
| `path` | unicode / `Path` | The path to load from |
%package help
Summary: Development documents and examples for sense2vec
Provides: python3-sense2vec-doc
%description help
### class `Sense2VecComponent`
The pipeline component to add sense2vec to spaCy pipelines.
#### method `Sense2VecComponent.__init__`
Initialize the pipeline component.
| Argument | Type | Description |
| --------------- | --------------------------------------------------------------------------------------------------------------------- | ----------------------------------------------------------------------------------------------------------- |
| `vocab` | `Vocab` | The shared `Vocab`. Mostly used for the shared `StringStore`. |
| `shape` | tuple | The vector shape. |
| `merge_phrases` | bool | Whether to merge sense2vec phrases into one token. Defaults to `False`. |
| `lemmatize` | bool | Always look up lemmas if available in the vectors, otherwise default to original word. Defaults to `False`. |
| `overrides` | Optional custom functions to use, mapped to names registred via the registry, e.g. `{"make_key": "custom_make_key"}`. |
| **RETURNS** | `Sense2VecComponent` | The newly constructed object. |
```python
s2v = Sense2VecComponent(nlp.vocab)
```
#### classmethod `Sense2VecComponent.from_nlp`
Initialize the component from an nlp object. Mostly used as the component
factory for the entry point (see setup.cfg) and to auto-register via the
`@spacy.component` decorator.
| Argument | Type | Description |
| ----------- | -------------------- | ----------------------------- |
| `nlp` | `Language` | The `nlp` object. |
| `**cfg` | - | Optional config parameters. |
| **RETURNS** | `Sense2VecComponent` | The newly constructed object. |
```python
s2v = Sense2VecComponent.from_nlp(nlp)
```
#### method `Sense2VecComponent.__call__`
Process a `Doc` object with the component. Typically only called as part of the
spaCy pipeline and not directly.
| Argument | Type | Description |
| ----------- | ----- | ------------------------ |
| `doc` | `Doc` | The document to process. |
| **RETURNS** | `Doc` | the processed document. |
#### method `Sense2Vec.init_component`
Register the component-specific extension attributes here and only if the
component is added to the pipeline and used – otherwise, tokens will still get
the attributes even if the component is only created and not added.
#### method `Sense2VecComponent.to_bytes`
Serialize the component to a bytestring. Also called when the component is added
to the pipeline and you run `nlp.to_bytes`.
| Argument | Type | Description |
| ----------- | ----- | ------------------------- |
| **RETURNS** | bytes | The serialized component. |
#### method `Sense2VecComponent.from_bytes`
Load a component from a bytestring. Also called when you run `nlp.from_bytes`.
| Argument | Type | Description |
| ------------ | -------------------- | ------------------ |
| `bytes_data` | bytes | The data to load. |
| **RETURNS** | `Sense2VecComponent` | The loaded object. |
#### method `Sense2VecComponent.to_disk`
Serialize the component to a directory. Also called when the component is added
to the pipeline and you run `nlp.to_disk`.
| Argument | Type | Description |
| -------- | ---------------- | ----------- |
| `path` | unicode / `Path` | The path. |
#### method `Sense2VecComponent.from_disk`
Load a `Sense2Vec` object from a directory. Also called when you run
`nlp.from_disk`.
| Argument | Type | Description |
| ----------- | -------------------- | --------------------- |
| `path` | unicode / `Path` | The path to load from |
%prep
%autosetup -n sense2vec-2.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sense2vec -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 2.0.2-1
- Package Spec generated