%global _empty_manifest_terminate_build 0
Name:		python-tox-direct
Version:	0.4
Release:	1
Summary:	plugin for tox - run everything directly (tox creates no virtual env)
License:	MIT
URL:		https://github.com/obestwalter/tox-direct
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e1/a7/910d5a3e1daec54743cb614c33d3c81aa1c13163ee132a3fea411f8107fd/tox-direct-0.4.tar.gz
BuildArch:	noarch

Requires:	python3-tox
Requires:	python3-py
Requires:	python3-pathlib2
Requires:	python3-twine
Requires:	python3-pytest

%description
[...] 
tox                3.13.1 
tox-direct         0.2.2  
[...]  
$ tox --version
3.13.1 imported from ~/.virtualenvs/tmp/lib/python3.6/site-packages/tox/__init__.py
registered plugins:
    tox-direct-0.2.2 at ~/.virtualenvs/tmp/lib/python3.6/site-packages/tox_direct/hookimpls.py
```
You have a project with a `tox.ini` like this:
```ini
[tox]
; this is the default - put here to be explicit
skipsdist = False
[testenv:direct-action]
; also the default to be explicit
skip_install = False
deps = pytest
commands =
    pip list
    which python
[testenv:env-attribute]
direct = True
; also the default to be explicit
skip_install = False
deps = pytest
commands =
    pip list
    which python
[testenv:normal]
whitelist_externals = which
skip_install = False
usedevelop = True
commands = which python
```
tun tox:
```text
$ tox -qr

%package -n python3-tox-direct
Summary:	plugin for tox - run everything directly (tox creates no virtual env)
Provides:	python-tox-direct
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-tox-direct
[...] 
tox                3.13.1 
tox-direct         0.2.2  
[...]  
$ tox --version
3.13.1 imported from ~/.virtualenvs/tmp/lib/python3.6/site-packages/tox/__init__.py
registered plugins:
    tox-direct-0.2.2 at ~/.virtualenvs/tmp/lib/python3.6/site-packages/tox_direct/hookimpls.py
```
You have a project with a `tox.ini` like this:
```ini
[tox]
; this is the default - put here to be explicit
skipsdist = False
[testenv:direct-action]
; also the default to be explicit
skip_install = False
deps = pytest
commands =
    pip list
    which python
[testenv:env-attribute]
direct = True
; also the default to be explicit
skip_install = False
deps = pytest
commands =
    pip list
    which python
[testenv:normal]
whitelist_externals = which
skip_install = False
usedevelop = True
commands = which python
```
tun tox:
```text
$ tox -qr

%package help
Summary:	Development documents and examples for tox-direct
Provides:	python3-tox-direct-doc
%description help
[...] 
tox                3.13.1 
tox-direct         0.2.2  
[...]  
$ tox --version
3.13.1 imported from ~/.virtualenvs/tmp/lib/python3.6/site-packages/tox/__init__.py
registered plugins:
    tox-direct-0.2.2 at ~/.virtualenvs/tmp/lib/python3.6/site-packages/tox_direct/hookimpls.py
```
You have a project with a `tox.ini` like this:
```ini
[tox]
; this is the default - put here to be explicit
skipsdist = False
[testenv:direct-action]
; also the default to be explicit
skip_install = False
deps = pytest
commands =
    pip list
    which python
[testenv:env-attribute]
direct = True
; also the default to be explicit
skip_install = False
deps = pytest
commands =
    pip list
    which python
[testenv:normal]
whitelist_externals = which
skip_install = False
usedevelop = True
commands = which python
```
tun tox:
```text
$ tox -qr

%prep
%autosetup -n tox-direct-0.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tox-direct -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4-1
- Package Spec generated