%global _empty_manifest_terminate_build 0
Name:		python-annotell-query
Version:	2.5.0
Release:	1
Summary:	Annotell Query API Client
License:	MIT
URL:		https://github.com/annotell/annotell-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4a/6a/8caae890d50cbc815294eabc051c03b008aa6e2f10768adf6a09e6639906/annotell-query-2.5.0.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-annotell-auth[requests]

%description
# Annotell Query API Client

Python 3 library providing access to the Annotell Query API. 

To install with pip run `pip install annotell-query`

Set env ANNOTELL_CREDENTIALS, see [annotell-auth](https://github.com/annotell/annotell-python/tree/master/annotell-auth). 

## Judgement Query Example
Stream all items matching a query
```python
from annotell.query.query_api_client import QueryApiClient
query_client = QueryApiClient()
resp = query_client.query_judgements(query_filter="requestId = X")
for item in resp.items():
    print(item)
```

## Change log

### 2.5.0
- A new base Query client that can be inherrited for other applications 

### 2.4.1
- Use `annotell-auth[requests]>=2.0.0`

### 2.3.0
- Use `annotell-auth>=1.6`
- Remove metadata queries

### 2.2.0
- Use `annotell-auth>=1.5` with fault tolerant auth request session

### 2.1.0
- Use server default query limits 

### 2.0.0
- Rename library to `annotell-query`
- Rename `QueryApi` to `QueryApiClient`
- Add KPI query method

### 1.3.0
- Change constructor for authentication to only accept `auth`. 



%package -n python3-annotell-query
Summary:	Annotell Query API Client
Provides:	python-annotell-query
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-annotell-query
# Annotell Query API Client

Python 3 library providing access to the Annotell Query API. 

To install with pip run `pip install annotell-query`

Set env ANNOTELL_CREDENTIALS, see [annotell-auth](https://github.com/annotell/annotell-python/tree/master/annotell-auth). 

## Judgement Query Example
Stream all items matching a query
```python
from annotell.query.query_api_client import QueryApiClient
query_client = QueryApiClient()
resp = query_client.query_judgements(query_filter="requestId = X")
for item in resp.items():
    print(item)
```

## Change log

### 2.5.0
- A new base Query client that can be inherrited for other applications 

### 2.4.1
- Use `annotell-auth[requests]>=2.0.0`

### 2.3.0
- Use `annotell-auth>=1.6`
- Remove metadata queries

### 2.2.0
- Use `annotell-auth>=1.5` with fault tolerant auth request session

### 2.1.0
- Use server default query limits 

### 2.0.0
- Rename library to `annotell-query`
- Rename `QueryApi` to `QueryApiClient`
- Add KPI query method

### 1.3.0
- Change constructor for authentication to only accept `auth`. 



%package help
Summary:	Development documents and examples for annotell-query
Provides:	python3-annotell-query-doc
%description help
# Annotell Query API Client

Python 3 library providing access to the Annotell Query API. 

To install with pip run `pip install annotell-query`

Set env ANNOTELL_CREDENTIALS, see [annotell-auth](https://github.com/annotell/annotell-python/tree/master/annotell-auth). 

## Judgement Query Example
Stream all items matching a query
```python
from annotell.query.query_api_client import QueryApiClient
query_client = QueryApiClient()
resp = query_client.query_judgements(query_filter="requestId = X")
for item in resp.items():
    print(item)
```

## Change log

### 2.5.0
- A new base Query client that can be inherrited for other applications 

### 2.4.1
- Use `annotell-auth[requests]>=2.0.0`

### 2.3.0
- Use `annotell-auth>=1.6`
- Remove metadata queries

### 2.2.0
- Use `annotell-auth>=1.5` with fault tolerant auth request session

### 2.1.0
- Use server default query limits 

### 2.0.0
- Rename library to `annotell-query`
- Rename `QueryApi` to `QueryApiClient`
- Add KPI query method

### 1.3.0
- Change constructor for authentication to only accept `auth`. 



%prep
%autosetup -n annotell-query-2.5.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-annotell-query -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 2.5.0-1
- Package Spec generated