%global _empty_manifest_terminate_build 0
Name: python-metrics
Version: 0.3.3
Release: 1
Summary: metrics for Python, C, C++, Go and Javascript code (plugins for pylint, pytest-cov, and git available)
License: MIT
URL: https://github.com/finklabs/metrics/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/01/ae/3ab18f2f3449f2e7931112c991ade9684eeddf96cea03ea7f662c01f0658/metrics-0.3.3.tar.gz
BuildArch: noarch
%description
The original idea of metrics was a platform that can be extended with
many different metrics. At the time I will focus only on SLOC and McCabe
complexity metrics. *metrics* is build in a way to support many, many
languages `supported languages `__.
Currently we test support for Python, C, C++, Go and JavaScript.
The SLOC metric counts the lines but excludes empty lines and comments.
This is sometimes referred to as the *source lines of code* (SLOC). In
literature this is often also referred as physical lines of code. I
simplified it to something which to my understanding is the common
denominator for the metric packages I looked into (CCCC, SLOCCount,
PyMetrics, Eclipse-Metrics, Ohcount).
%package -n python3-metrics
Summary: metrics for Python, C, C++, Go and Javascript code (plugins for pylint, pytest-cov, and git available)
Provides: python-metrics
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-metrics
The original idea of metrics was a platform that can be extended with
many different metrics. At the time I will focus only on SLOC and McCabe
complexity metrics. *metrics* is build in a way to support many, many
languages `supported languages `__.
Currently we test support for Python, C, C++, Go and JavaScript.
The SLOC metric counts the lines but excludes empty lines and comments.
This is sometimes referred to as the *source lines of code* (SLOC). In
literature this is often also referred as physical lines of code. I
simplified it to something which to my understanding is the common
denominator for the metric packages I looked into (CCCC, SLOCCount,
PyMetrics, Eclipse-Metrics, Ohcount).
%package help
Summary: Development documents and examples for metrics
Provides: python3-metrics-doc
%description help
The original idea of metrics was a platform that can be extended with
many different metrics. At the time I will focus only on SLOC and McCabe
complexity metrics. *metrics* is build in a way to support many, many
languages `supported languages `__.
Currently we test support for Python, C, C++, Go and JavaScript.
The SLOC metric counts the lines but excludes empty lines and comments.
This is sometimes referred to as the *source lines of code* (SLOC). In
literature this is often also referred as physical lines of code. I
simplified it to something which to my understanding is the common
denominator for the metric packages I looked into (CCCC, SLOCCount,
PyMetrics, Eclipse-Metrics, Ohcount).
%prep
%autosetup -n metrics-0.3.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-metrics -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.3.3-1
- Package Spec generated