%global _empty_manifest_terminate_build 0
Name: python-dkist-fits-specifications
Version: 3.6.0
Release: 1
Summary: Machine readable FITS specifications for DKIST data.
License: BSD 3-Clause
URL: https://bitbucket.org/dkistdc/dkist-fits-specifications/src/main/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7a/cf/9f94b938e4daef460ad26c4e616b477ede04498f4c9f74bd75411c4fdf98/dkist_fits_specifications-3.6.0.tar.gz
BuildArch: noarch
Requires: python3-yamale
Requires: python3-pyyaml
Requires: python3-astropy
Requires: python3-sphinx
Requires: python3-sphinx-automodapi
Requires: python3-sphinx-autodoc-typehints
Requires: python3-sphinx-changelog
Requires: python3-dkist-sphinx-theme
Requires: python3-towncrier
Requires: python3-pytest
Requires: python3-pytest-doctestplus
Requires: python3-pytest-cov
Requires: python3-docutils
Requires: python3-sphinx
Requires: python3-towncrier
%description
This repository contains machine readable versions of DKIST specifications for
FITS files. Specifically corresponding to SPEC122 RevE and SPEC214 RevA.
data.
This repository is used alongside the `dkist-header-validator `__ to validate that SPEC122 or SPEC214 data is compliant with these DKIST specifications. To use the validator, please click `here `__ and follow the installation instructions.
%package -n python3-dkist-fits-specifications
Summary: Machine readable FITS specifications for DKIST data.
Provides: python-dkist-fits-specifications
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dkist-fits-specifications
This repository contains machine readable versions of DKIST specifications for
FITS files. Specifically corresponding to SPEC122 RevE and SPEC214 RevA.
data.
This repository is used alongside the `dkist-header-validator `__ to validate that SPEC122 or SPEC214 data is compliant with these DKIST specifications. To use the validator, please click `here `__ and follow the installation instructions.
%package help
Summary: Development documents and examples for dkist-fits-specifications
Provides: python3-dkist-fits-specifications-doc
%description help
This repository contains machine readable versions of DKIST specifications for
FITS files. Specifically corresponding to SPEC122 RevE and SPEC214 RevA.
data.
This repository is used alongside the `dkist-header-validator `__ to validate that SPEC122 or SPEC214 data is compliant with these DKIST specifications. To use the validator, please click `here `__ and follow the installation instructions.
%prep
%autosetup -n dkist-fits-specifications-3.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dkist-fits-specifications -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 3.6.0-1
- Package Spec generated