%global _empty_manifest_terminate_build 0
Name: python-root-numpy
Version: 4.8.0
Release: 1
Summary: The interface between ROOT and NumPy
License: new BSD
URL: http://scikit-hep.org/root_numpy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d5/5f/82f5111c22599676eb8b5f9b1bf85c38dcc7995d52cd6b4a8f5f5caa4659/root_numpy-4.8.0.tar.gz
BuildArch: noarch
%description
.. image:: https://img.shields.io/pypi/v/root_numpy.svg
:target: https://pypi.python.org/pypi/root_numpy
.. image:: https://api.travis-ci.org/scikit-hep/root_numpy.png
:target: https://travis-ci.org/scikit-hep/root_numpy
.. image:: https://coveralls.io/repos/github/scikit-hep/root_numpy/badge.svg?branch=master
:target: https://coveralls.io/github/scikit-hep/root_numpy?branch=master
.. image:: https://landscape.io/github/scikit-hep/root_numpy/master/landscape.svg?style=flat
:target: https://landscape.io/github/scikit-hep/root_numpy/master
.. image:: https://zenodo.org/badge/DOI/10.5281/zenodo.592881.svg
:target: https://doi.org/10.5281/zenodo.592881
root_numpy is a Python extension module that provides an efficient interface
between `ROOT `_ and `NumPy `_.
root_numpy's internals are compiled C++ and can therefore handle large amounts
of data much faster than equivalent pure Python implementations.
With your ROOT data in NumPy form, make use of NumPy's `broad library
`_, including fancy indexing,
slicing, broadcasting, random sampling, sorting, shape transformations, linear
algebra operations, and more. See this `tutorial
`_ to get started.
NumPy is the fundamental library of the scientific Python ecosystem. Using
NumPy arrays opens up many new possibilities beyond what ROOT offers. Convert
your TTrees into NumPy arrays and use `SciPy `_ for
numerical integration and optimization, `matplotlib `_
for plotting, `pandas `_ for data analysis,
`statsmodels `_ for statistical modelling,
`scikit-learn `_ for machine learning, and perform
quick exploratory analysis in a `Jupyter notebook `_.
At the core of root_numpy are powerful and flexible functions for converting
`ROOT TTrees `_ into
`structured NumPy arrays
`_ as well as converting
NumPy arrays back into ROOT TTrees. root_numpy can convert branches of strings
and basic types such as bool, int, float, double, etc. as well as
variable-length and fixed-length multidimensional arrays and 1D or 2D vectors
of basic types and strings. root_numpy can also create columns in the output
array that are expressions involving the TTree branches similar to
``TTree::Draw()``.
%package -n python3-root-numpy
Summary: The interface between ROOT and NumPy
Provides: python-root-numpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-root-numpy
.. image:: https://img.shields.io/pypi/v/root_numpy.svg
:target: https://pypi.python.org/pypi/root_numpy
.. image:: https://api.travis-ci.org/scikit-hep/root_numpy.png
:target: https://travis-ci.org/scikit-hep/root_numpy
.. image:: https://coveralls.io/repos/github/scikit-hep/root_numpy/badge.svg?branch=master
:target: https://coveralls.io/github/scikit-hep/root_numpy?branch=master
.. image:: https://landscape.io/github/scikit-hep/root_numpy/master/landscape.svg?style=flat
:target: https://landscape.io/github/scikit-hep/root_numpy/master
.. image:: https://zenodo.org/badge/DOI/10.5281/zenodo.592881.svg
:target: https://doi.org/10.5281/zenodo.592881
root_numpy is a Python extension module that provides an efficient interface
between `ROOT `_ and `NumPy `_.
root_numpy's internals are compiled C++ and can therefore handle large amounts
of data much faster than equivalent pure Python implementations.
With your ROOT data in NumPy form, make use of NumPy's `broad library
`_, including fancy indexing,
slicing, broadcasting, random sampling, sorting, shape transformations, linear
algebra operations, and more. See this `tutorial
`_ to get started.
NumPy is the fundamental library of the scientific Python ecosystem. Using
NumPy arrays opens up many new possibilities beyond what ROOT offers. Convert
your TTrees into NumPy arrays and use `SciPy `_ for
numerical integration and optimization, `matplotlib `_
for plotting, `pandas `_ for data analysis,
`statsmodels `_ for statistical modelling,
`scikit-learn `_ for machine learning, and perform
quick exploratory analysis in a `Jupyter notebook `_.
At the core of root_numpy are powerful and flexible functions for converting
`ROOT TTrees `_ into
`structured NumPy arrays
`_ as well as converting
NumPy arrays back into ROOT TTrees. root_numpy can convert branches of strings
and basic types such as bool, int, float, double, etc. as well as
variable-length and fixed-length multidimensional arrays and 1D or 2D vectors
of basic types and strings. root_numpy can also create columns in the output
array that are expressions involving the TTree branches similar to
``TTree::Draw()``.
%package help
Summary: Development documents and examples for root-numpy
Provides: python3-root-numpy-doc
%description help
.. image:: https://img.shields.io/pypi/v/root_numpy.svg
:target: https://pypi.python.org/pypi/root_numpy
.. image:: https://api.travis-ci.org/scikit-hep/root_numpy.png
:target: https://travis-ci.org/scikit-hep/root_numpy
.. image:: https://coveralls.io/repos/github/scikit-hep/root_numpy/badge.svg?branch=master
:target: https://coveralls.io/github/scikit-hep/root_numpy?branch=master
.. image:: https://landscape.io/github/scikit-hep/root_numpy/master/landscape.svg?style=flat
:target: https://landscape.io/github/scikit-hep/root_numpy/master
.. image:: https://zenodo.org/badge/DOI/10.5281/zenodo.592881.svg
:target: https://doi.org/10.5281/zenodo.592881
root_numpy is a Python extension module that provides an efficient interface
between `ROOT `_ and `NumPy `_.
root_numpy's internals are compiled C++ and can therefore handle large amounts
of data much faster than equivalent pure Python implementations.
With your ROOT data in NumPy form, make use of NumPy's `broad library
`_, including fancy indexing,
slicing, broadcasting, random sampling, sorting, shape transformations, linear
algebra operations, and more. See this `tutorial
`_ to get started.
NumPy is the fundamental library of the scientific Python ecosystem. Using
NumPy arrays opens up many new possibilities beyond what ROOT offers. Convert
your TTrees into NumPy arrays and use `SciPy `_ for
numerical integration and optimization, `matplotlib `_
for plotting, `pandas `_ for data analysis,
`statsmodels `_ for statistical modelling,
`scikit-learn `_ for machine learning, and perform
quick exploratory analysis in a `Jupyter notebook `_.
At the core of root_numpy are powerful and flexible functions for converting
`ROOT TTrees `_ into
`structured NumPy arrays
`_ as well as converting
NumPy arrays back into ROOT TTrees. root_numpy can convert branches of strings
and basic types such as bool, int, float, double, etc. as well as
variable-length and fixed-length multidimensional arrays and 1D or 2D vectors
of basic types and strings. root_numpy can also create columns in the output
array that are expressions involving the TTree branches similar to
``TTree::Draw()``.
%prep
%autosetup -n root-numpy-4.8.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-root-numpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 4.8.0-1
- Package Spec generated