%global _empty_manifest_terminate_build 0
Name:		python-django-jsonforms
Version:	1.1.2
Release:	1
Summary:	JSON Schema forms for Django
License:	BSD
URL:		https://github.com/Aristotle-Metadata-Enterprises/django-jsonforms
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f2/be/0cb73c6952de1996080db930ac1e91443771748d73817ff615bb371be2ea/django-jsonforms-1.1.2.tar.gz
BuildArch:	noarch

Requires:	python3-jsonschema
Requires:	python3-django

%description
django-jsonforms provides a Django integration of json-editor (https://github.com/json-editor/json-editor).
A form field is provided that renders the dynamic form created by json-editor, loading in the provided schema and options along with any initial form data.
The field can be rendered in the same way as any other django field and also validates submitted data against your json schema on submission.

%package -n python3-django-jsonforms
Summary:	JSON Schema forms for Django
Provides:	python-django-jsonforms
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-jsonforms
django-jsonforms provides a Django integration of json-editor (https://github.com/json-editor/json-editor).
A form field is provided that renders the dynamic form created by json-editor, loading in the provided schema and options along with any initial form data.
The field can be rendered in the same way as any other django field and also validates submitted data against your json schema on submission.

%package help
Summary:	Development documents and examples for django-jsonforms
Provides:	python3-django-jsonforms-doc
%description help
django-jsonforms provides a Django integration of json-editor (https://github.com/json-editor/json-editor).
A form field is provided that renders the dynamic form created by json-editor, loading in the provided schema and options along with any initial form data.
The field can be rendered in the same way as any other django field and also validates submitted data against your json schema on submission.

%prep
%autosetup -n django-jsonforms-1.1.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-jsonforms -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.2-1
- Package Spec generated