%global _empty_manifest_terminate_build 0
Name:		python-pynapl
Version:	0.0.8
Release:	1
Summary:	Python Native Automation Package Library
License:	MIT License
URL:		https://github.com/sgriffith3/pynapl
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/09/b5/f972eaf392932da4efe7dc818e15091725dd7be8eb7f57f85ae897094a30/pynapl-0.0.8.tar.gz
BuildArch:	noarch


%description
# pynapl

**Python Native Automation Package Library**

The Tastiest Code You May Ever Consume 

## Overview
**pynapl** is the conglomeration of useful tactics that I have made work for my personal and professional automation. The hope is for **pynapl** to evolve and become something more (someday - Exeggutor!!!). 

Currently, **pynapl** will allow you to send emails. More will come!

#### Details
**pynapl.send_mail()**

This is a script to send out an HTML email.

#### NEVER TESTED ON REAL FRUIT
No warranties. No guarantees. But feel free to enjoy as you please. 

### License

**pynapl** is registered under the MIT license.

That means if you use it, mention me (keep the license in place) and we're cool.




%package -n python3-pynapl
Summary:	Python Native Automation Package Library
Provides:	python-pynapl
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pynapl
# pynapl

**Python Native Automation Package Library**

The Tastiest Code You May Ever Consume 

## Overview
**pynapl** is the conglomeration of useful tactics that I have made work for my personal and professional automation. The hope is for **pynapl** to evolve and become something more (someday - Exeggutor!!!). 

Currently, **pynapl** will allow you to send emails. More will come!

#### Details
**pynapl.send_mail()**

This is a script to send out an HTML email.

#### NEVER TESTED ON REAL FRUIT
No warranties. No guarantees. But feel free to enjoy as you please. 

### License

**pynapl** is registered under the MIT license.

That means if you use it, mention me (keep the license in place) and we're cool.




%package help
Summary:	Development documents and examples for pynapl
Provides:	python3-pynapl-doc
%description help
# pynapl

**Python Native Automation Package Library**

The Tastiest Code You May Ever Consume 

## Overview
**pynapl** is the conglomeration of useful tactics that I have made work for my personal and professional automation. The hope is for **pynapl** to evolve and become something more (someday - Exeggutor!!!). 

Currently, **pynapl** will allow you to send emails. More will come!

#### Details
**pynapl.send_mail()**

This is a script to send out an HTML email.

#### NEVER TESTED ON REAL FRUIT
No warranties. No guarantees. But feel free to enjoy as you please. 

### License

**pynapl** is registered under the MIT license.

That means if you use it, mention me (keep the license in place) and we're cool.




%prep
%autosetup -n pynapl-0.0.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pynapl -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.8-1
- Package Spec generated