%global _empty_manifest_terminate_build 0
Name:		python-tinydb-appengine
Version:	1.0.6
Release:	1
Summary:	TinyDB Extension for AppEngine
License:	MIT
URL:		https://github.com/imalento/tinydb-appengine
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/9d/30/0301c536fc1501015ad3bbd4e9ec35d3a4aa25499e4d9ec95c3fa5254eb4/tinydb-appengine-1.0.6.tar.gz
BuildArch:	noarch


%description
# tinydb-appengine

__tinydb-appengine__ provides TinyDB storage for App Engine. You can use JSON readonly.

## Installation

```bash
$ pip install tinydb-appengine
```

## Usage

```python
from tinydb import TinyDB
from tinydb_appengine.storages import EphemeralJSONStorage
db = TinyDB('your_data.json', storage=EphemeralJSONStorage)
```




%package -n python3-tinydb-appengine
Summary:	TinyDB Extension for AppEngine
Provides:	python-tinydb-appengine
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-tinydb-appengine
# tinydb-appengine

__tinydb-appengine__ provides TinyDB storage for App Engine. You can use JSON readonly.

## Installation

```bash
$ pip install tinydb-appengine
```

## Usage

```python
from tinydb import TinyDB
from tinydb_appengine.storages import EphemeralJSONStorage
db = TinyDB('your_data.json', storage=EphemeralJSONStorage)
```




%package help
Summary:	Development documents and examples for tinydb-appengine
Provides:	python3-tinydb-appengine-doc
%description help
# tinydb-appengine

__tinydb-appengine__ provides TinyDB storage for App Engine. You can use JSON readonly.

## Installation

```bash
$ pip install tinydb-appengine
```

## Usage

```python
from tinydb import TinyDB
from tinydb_appengine.storages import EphemeralJSONStorage
db = TinyDB('your_data.json', storage=EphemeralJSONStorage)
```




%prep
%autosetup -n tinydb-appengine-1.0.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tinydb-appengine -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.6-1
- Package Spec generated