%global _empty_manifest_terminate_build 0
Name:		python-tronalddump
Version:	0.4
Release:	1
Summary:	Donald Trump quotes
License:	GNU v3
URL:		https://bitbucket.org/dabcoder/tronalddump
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/fb/02/ac2d1d38a86d89c550be1cab4bd8342f34ceaa2fdef0dab0ac769ddb617d/tronalddump-0.4.tar.gz
BuildArch:	noarch

Requires:	python3-requests

%description
Python wrapper for the Tronald Dump API: https://docs.tronalddump.io/




%package -n python3-tronalddump
Summary:	Donald Trump quotes
Provides:	python-tronalddump
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-tronalddump
Python wrapper for the Tronald Dump API: https://docs.tronalddump.io/




%package help
Summary:	Development documents and examples for tronalddump
Provides:	python3-tronalddump-doc
%description help
Python wrapper for the Tronald Dump API: https://docs.tronalddump.io/




%prep
%autosetup -n tronalddump-0.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tronalddump -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4-1
- Package Spec generated