%global _empty_manifest_terminate_build 0
Name: python-PyPtt
Version: 1.0.7
Release: 1
Summary: PyPtt
License: GNU Lesser General Public License v3 (LGPLv3)
URL: https://github.com/PyPtt/PyPtt
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d8/2f/fc4838cf40b6c6d247f1137e30c7161a11ddcf642ef73934031c35d80b73/PyPtt-1.0.7.tar.gz
BuildArch: noarch
Requires: python3-progressbar2
Requires: python3-websockets
Requires: python3-uao
Requires: python3-SingleLog
Requires: python3-requests
Requires: python3-AutoStrEnum
%description

# PyPtt
[](https://pypi.python.org/pypi/PyPtt)

[](https://www.codacy.com/manual/PttCodingMan/PyPtt?utm_source=github.com&utm_medium=referral&utm_content=PttCodingMan/PyPtt&utm_campaign=Badge_Grade)

[](https://www.gnu.org/licenses/lgpl-3.0)
[](https://t.me/PyPtt)
[](http://paypal.me/CodingMan)
#### PyPtt (PTT Library) 是一套 Pure Python PTT API。具備大部分常用功能,無論推文、發文、爬蟲、寄信、發 P 幣、丟水球或者追蹤帳號
你都可以在這裡找到完整的使用範例
#### API 的詳細範例與參數說明 PyPtt 文件 [0.9 版本(封存)](https://github.com/PyPtt/PyPtt/tree/1700147753fde9c920cab8c2e484384f6cedd6f3/doc), [1.0 版本](https://pyptt.cc/)
#### Pypi: https://pypi.org/project/PyPtt/
## 為什麼選擇 PyPtt
#### 完整的支援: PyPtt 是目前支援最完整的 PTT API,除了 PTT 也相容於 PTT2
#### 即時的爬蟲: 登入式爬蟲,除了可以取得即時的推文,也可以下條件搜尋,不需要整個版都爬下來還需要清洗資料最後才能分析
#### 快速的客服: 如果有任何問題你可以在 [](https://t.me/PyPtt) 找到我
## 版本
#### [](https://pypi.python.org/pypi/PyPtt)
## 安裝
Pypi: [https://pypi.org/project/PyPtt/](https://pypi.org/project/PyPtt/)
```bash
pip install PyPtt
```
## 回報問題
#### 1. 請先閱讀 PyPtt 文件 [0.9 版本](https://github.com/PttCodingMan/PyPtt/tree/master/doc), [1.0 版本](https://pyptt.cc/)
#### 確認使用方法無誤並確認你所使用的版本為 [](https://pypi.python.org/pypi/PyPtt) 如果是舊版本請更新後重新測試
#### 2. 如果問題還是存在,請參考文件中的 [初始設定](https://github.com/PttCodingMan/PyPtt/tree/master/doc#%E5%88%9D%E5%A7%8B%E8%A8%AD%E5%AE%9A) 將 log_level 調整成 PTT.Logger.TRACE 後截圖並附上使用 PyPtt 的相關程式碼 [重要]
#### 3. 請用友善的態度開個 [issue](https://github.com/PttCodingMan/PyPtt/issues/new) 追蹤問題
## 需求
#### Python ≥ 3.8
## 立場聲明
#### 本專案意旨在提供 PTT 自動化機器人函式庫,並無意違反任何 PTT 站方規範。
#### 如有牴觸,請馬上告知。
## 贊助
#### 如果這個專案對你有幫助,贊助我一杯咖啡吧!!
####
#### [](http://paypal.me/CodingMan)
## 贊助清單
#### leftc
%package -n python3-PyPtt
Summary: PyPtt
Provides: python-PyPtt
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PyPtt

# PyPtt
[](https://pypi.python.org/pypi/PyPtt)

[](https://www.codacy.com/manual/PttCodingMan/PyPtt?utm_source=github.com&utm_medium=referral&utm_content=PttCodingMan/PyPtt&utm_campaign=Badge_Grade)

[](https://www.gnu.org/licenses/lgpl-3.0)
[](https://t.me/PyPtt)
[](http://paypal.me/CodingMan)
#### PyPtt (PTT Library) 是一套 Pure Python PTT API。具備大部分常用功能,無論推文、發文、爬蟲、寄信、發 P 幣、丟水球或者追蹤帳號
你都可以在這裡找到完整的使用範例
#### API 的詳細範例與參數說明 PyPtt 文件 [0.9 版本(封存)](https://github.com/PyPtt/PyPtt/tree/1700147753fde9c920cab8c2e484384f6cedd6f3/doc), [1.0 版本](https://pyptt.cc/)
#### Pypi: https://pypi.org/project/PyPtt/
## 為什麼選擇 PyPtt
#### 完整的支援: PyPtt 是目前支援最完整的 PTT API,除了 PTT 也相容於 PTT2
#### 即時的爬蟲: 登入式爬蟲,除了可以取得即時的推文,也可以下條件搜尋,不需要整個版都爬下來還需要清洗資料最後才能分析
#### 快速的客服: 如果有任何問題你可以在 [](https://t.me/PyPtt) 找到我
## 版本
#### [](https://pypi.python.org/pypi/PyPtt)
## 安裝
Pypi: [https://pypi.org/project/PyPtt/](https://pypi.org/project/PyPtt/)
```bash
pip install PyPtt
```
## 回報問題
#### 1. 請先閱讀 PyPtt 文件 [0.9 版本](https://github.com/PttCodingMan/PyPtt/tree/master/doc), [1.0 版本](https://pyptt.cc/)
#### 確認使用方法無誤並確認你所使用的版本為 [](https://pypi.python.org/pypi/PyPtt) 如果是舊版本請更新後重新測試
#### 2. 如果問題還是存在,請參考文件中的 [初始設定](https://github.com/PttCodingMan/PyPtt/tree/master/doc#%E5%88%9D%E5%A7%8B%E8%A8%AD%E5%AE%9A) 將 log_level 調整成 PTT.Logger.TRACE 後截圖並附上使用 PyPtt 的相關程式碼 [重要]
#### 3. 請用友善的態度開個 [issue](https://github.com/PttCodingMan/PyPtt/issues/new) 追蹤問題
## 需求
#### Python ≥ 3.8
## 立場聲明
#### 本專案意旨在提供 PTT 自動化機器人函式庫,並無意違反任何 PTT 站方規範。
#### 如有牴觸,請馬上告知。
## 贊助
#### 如果這個專案對你有幫助,贊助我一杯咖啡吧!!
####
#### [](http://paypal.me/CodingMan)
## 贊助清單
#### leftc
%package help
Summary: Development documents and examples for PyPtt
Provides: python3-PyPtt-doc
%description help

# PyPtt
[](https://pypi.python.org/pypi/PyPtt)

[](https://www.codacy.com/manual/PttCodingMan/PyPtt?utm_source=github.com&utm_medium=referral&utm_content=PttCodingMan/PyPtt&utm_campaign=Badge_Grade)

[](https://www.gnu.org/licenses/lgpl-3.0)
[](https://t.me/PyPtt)
[](http://paypal.me/CodingMan)
#### PyPtt (PTT Library) 是一套 Pure Python PTT API。具備大部分常用功能,無論推文、發文、爬蟲、寄信、發 P 幣、丟水球或者追蹤帳號
你都可以在這裡找到完整的使用範例
#### API 的詳細範例與參數說明 PyPtt 文件 [0.9 版本(封存)](https://github.com/PyPtt/PyPtt/tree/1700147753fde9c920cab8c2e484384f6cedd6f3/doc), [1.0 版本](https://pyptt.cc/)
#### Pypi: https://pypi.org/project/PyPtt/
## 為什麼選擇 PyPtt
#### 完整的支援: PyPtt 是目前支援最完整的 PTT API,除了 PTT 也相容於 PTT2
#### 即時的爬蟲: 登入式爬蟲,除了可以取得即時的推文,也可以下條件搜尋,不需要整個版都爬下來還需要清洗資料最後才能分析
#### 快速的客服: 如果有任何問題你可以在 [](https://t.me/PyPtt) 找到我
## 版本
#### [](https://pypi.python.org/pypi/PyPtt)
## 安裝
Pypi: [https://pypi.org/project/PyPtt/](https://pypi.org/project/PyPtt/)
```bash
pip install PyPtt
```
## 回報問題
#### 1. 請先閱讀 PyPtt 文件 [0.9 版本](https://github.com/PttCodingMan/PyPtt/tree/master/doc), [1.0 版本](https://pyptt.cc/)
#### 確認使用方法無誤並確認你所使用的版本為 [](https://pypi.python.org/pypi/PyPtt) 如果是舊版本請更新後重新測試
#### 2. 如果問題還是存在,請參考文件中的 [初始設定](https://github.com/PttCodingMan/PyPtt/tree/master/doc#%E5%88%9D%E5%A7%8B%E8%A8%AD%E5%AE%9A) 將 log_level 調整成 PTT.Logger.TRACE 後截圖並附上使用 PyPtt 的相關程式碼 [重要]
#### 3. 請用友善的態度開個 [issue](https://github.com/PttCodingMan/PyPtt/issues/new) 追蹤問題
## 需求
#### Python ≥ 3.8
## 立場聲明
#### 本專案意旨在提供 PTT 自動化機器人函式庫,並無意違反任何 PTT 站方規範。
#### 如有牴觸,請馬上告知。
## 贊助
#### 如果這個專案對你有幫助,贊助我一杯咖啡吧!!
####
#### [](http://paypal.me/CodingMan)
## 贊助清單
#### leftc
%prep
%autosetup -n PyPtt-1.0.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PyPtt -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.0.7-1
- Package Spec generated