%global _empty_manifest_terminate_build 0
Name:		python-endplay
Version:	0.4.11b0
Release:	1
Summary:	A suite of tools for generation and analysis of bridge deals
License:	MIT License
URL:		https://github.com/dominicprice/endplay
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6e/58/bb59c9e7253b17670ca2d00d817f5efd45f786e7ff3f361ffc345cdb7da0/endplay-0.4.11b0.tar.gz

Requires:	python3-pyparsing
Requires:	python3-tqdm
Requires:	python3-numpy
Requires:	python3-matplotlib
Requires:	python3-more-itertools

%description


%package -n python3-endplay
Summary:	A suite of tools for generation and analysis of bridge deals
Provides:	python-endplay
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-endplay


%package help
Summary:	Development documents and examples for endplay
Provides:	python3-endplay-doc
%description help


%prep
%autosetup -n endplay-0.4.11b0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-endplay -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.11b0-1
- Package Spec generated