%global _empty_manifest_terminate_build 0
Name:		python-tagui
Version:	1.48.1
Release:	1
Summary:	RPA for Python is a Python package for RPA (robotic process automation)
License:	Apache License 2.0
URL:		https://github.com/tebelorg/RPA-Python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/da/63/f9b86046dfd10a486b7a9cba4408a418606b72a7bcb866d383a901ade74b/tagui-1.48.1.tar.gz
BuildArch:	noarch


%description
RPA for Python's simple and powerful API makes robotic process automation fun! You can use it to quickly automate away repetitive time-consuming tasks on websites, desktop applications, or the command line.

Built on AI Singapore's TagUI open-source RPA tool, RPA capabilities out-of-the-box for this package include website automation, computer vision automation, optical character recognition, keyboard & mouse automation.

Tables can't be displayed here, please refer to RPA for Python homepage for full API - https://github.com/tebelorg/RPA-Python

%package -n python3-tagui
Summary:	RPA for Python is a Python package for RPA (robotic process automation)
Provides:	python-tagui
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-tagui
RPA for Python's simple and powerful API makes robotic process automation fun! You can use it to quickly automate away repetitive time-consuming tasks on websites, desktop applications, or the command line.

Built on AI Singapore's TagUI open-source RPA tool, RPA capabilities out-of-the-box for this package include website automation, computer vision automation, optical character recognition, keyboard & mouse automation.

Tables can't be displayed here, please refer to RPA for Python homepage for full API - https://github.com/tebelorg/RPA-Python

%package help
Summary:	Development documents and examples for tagui
Provides:	python3-tagui-doc
%description help
RPA for Python's simple and powerful API makes robotic process automation fun! You can use it to quickly automate away repetitive time-consuming tasks on websites, desktop applications, or the command line.

Built on AI Singapore's TagUI open-source RPA tool, RPA capabilities out-of-the-box for this package include website automation, computer vision automation, optical character recognition, keyboard & mouse automation.

Tables can't be displayed here, please refer to RPA for Python homepage for full API - https://github.com/tebelorg/RPA-Python

%prep
%autosetup -n tagui-1.48.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tagui -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.48.1-1
- Package Spec generated