%global _empty_manifest_terminate_build 0
Name:		python-dougrain
Version:	0.5.1
Release:	1
Summary:	HAL JSON parser and generator
License:	UNKNOWN
URL:		http://github.com/wharris/dougrain/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ae/60/fb9caaaf878440d378a31078e80afd50640c437a1d95bbbb987f1a316f78/dougrain-0.5.1.tar.gz
BuildArch:	noarch


%description
Dougrain is a Python library to help you work with the JSON variant of the
`Hypertext Application Language <http://stateless.co/hal_specification.html>`_
(HAL). It uses Python objects to represent the JSON document, so you can use
it with whichever JSON library you prefer.

%package -n python3-dougrain
Summary:	HAL JSON parser and generator
Provides:	python-dougrain
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-dougrain
Dougrain is a Python library to help you work with the JSON variant of the
`Hypertext Application Language <http://stateless.co/hal_specification.html>`_
(HAL). It uses Python objects to represent the JSON document, so you can use
it with whichever JSON library you prefer.

%package help
Summary:	Development documents and examples for dougrain
Provides:	python3-dougrain-doc
%description help
Dougrain is a Python library to help you work with the JSON variant of the
`Hypertext Application Language <http://stateless.co/hal_specification.html>`_
(HAL). It uses Python objects to represent the JSON document, so you can use
it with whichever JSON library you prefer.

%prep
%autosetup -n dougrain-0.5.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-dougrain -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.1-1
- Package Spec generated