%global _empty_manifest_terminate_build 0
Name:		python-django-oscar-cch
Version:	7.1.0
Release:	1
Summary:	Integration between django-oscar and the CCH Sales Tax Office SOAP API.
License:	ISC
URL:		https://gitlab.com/thelabnyc/django-oscar/django-oscar-cch
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d7/a8/77fc28e8ea77c6964a849edd4e3d6b790b750fd4c4593d1fd9794b370b57/django-oscar-cch-7.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-django
Requires:	python3-django-oscar
Requires:	python3-instrumented-soap
Requires:	python3-pybreaker
Requires:	python3-coverage
Requires:	python3-flake8
Requires:	python3-freezegun
Requires:	python3-lxml
Requires:	python3-psycopg2cffi
Requires:	python3-sorl-thumbnail
Requires:	python3-sphinx-rtd-theme
Requires:	python3-sphinx
Requires:	python3-tox
Requires:	python3-unittest-xml-reporting
Requires:	python3-versiontag

%description


%package -n python3-django-oscar-cch
Summary:	Integration between django-oscar and the CCH Sales Tax Office SOAP API.
Provides:	python-django-oscar-cch
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-oscar-cch


%package help
Summary:	Development documents and examples for django-oscar-cch
Provides:	python3-django-oscar-cch-doc
%description help


%prep
%autosetup -n django-oscar-cch-7.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-oscar-cch -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 7.1.0-1
- Package Spec generated