%global _empty_manifest_terminate_build 0
Name: python-hashID
Version: 3.1.4
Release: 1
Summary: Software to identify the different types of hashes
License: GNU GPL
URL: https://github.com/psypanda/hashID
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/09/ce/d26df4843e6d62ce016a126e8faae1905b6f2b5629a59982dd3af23761aa/hashID-3.1.4.zip
BuildArch: noarch
%description
Identify the different types of hashes used to encrypt data and especially passwords.
This tool replaces `hash-identifier `__, which
is outdated!
hashID is a tool written in Python 3 which supports the
identification of over 220 unique hash types using regular expressions.
A detailed list of supported hashes can be found
`here `__.
It is able to identify a single hash, parse a file or read multiple
files in a directory and identify the hashes within them.
hashID is also capable of including the corresponding
`hashcat `__ mode and/or
`JohnTheRipper `__ format in its output.
hashID works out of the box with Python 2 ≥ 2.7.x or Python 3 ≥ 3.3 on any platform.
*Note: When identifying a hash on *nix operating systems use single
quotes to prevent interpolation*
%package -n python3-hashID
Summary: Software to identify the different types of hashes
Provides: python-hashID
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-hashID
Identify the different types of hashes used to encrypt data and especially passwords.
This tool replaces `hash-identifier `__, which
is outdated!
hashID is a tool written in Python 3 which supports the
identification of over 220 unique hash types using regular expressions.
A detailed list of supported hashes can be found
`here `__.
It is able to identify a single hash, parse a file or read multiple
files in a directory and identify the hashes within them.
hashID is also capable of including the corresponding
`hashcat `__ mode and/or
`JohnTheRipper `__ format in its output.
hashID works out of the box with Python 2 ≥ 2.7.x or Python 3 ≥ 3.3 on any platform.
*Note: When identifying a hash on *nix operating systems use single
quotes to prevent interpolation*
%package help
Summary: Development documents and examples for hashID
Provides: python3-hashID-doc
%description help
Identify the different types of hashes used to encrypt data and especially passwords.
This tool replaces `hash-identifier `__, which
is outdated!
hashID is a tool written in Python 3 which supports the
identification of over 220 unique hash types using regular expressions.
A detailed list of supported hashes can be found
`here `__.
It is able to identify a single hash, parse a file or read multiple
files in a directory and identify the hashes within them.
hashID is also capable of including the corresponding
`hashcat `__ mode and/or
`JohnTheRipper `__ format in its output.
hashID works out of the box with Python 2 ≥ 2.7.x or Python 3 ≥ 3.3 on any platform.
*Note: When identifying a hash on *nix operating systems use single
quotes to prevent interpolation*
%prep
%autosetup -n hashID-3.1.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-hashID -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 3.1.4-1
- Package Spec generated