%global _empty_manifest_terminate_build 0
Name: python-diffgram
Version: 0.13.0
Release: 1
Summary: SDK for Diffgram
License: MIT License
URL: https://github.com/diffgram/python-sdk
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b0/04/5ddd1ea067b5f70dd7a79aafadda477a70c5bc892c18bcb0fe94fc800929/diffgram-0.13.0.tar.gz
BuildArch: noarch
Requires: python3-imageio
Requires: python3-pillow
Requires: python3-requests
Requires: python3-scipy
Requires: python3-six
%description
# SDK for Diffgram
This is the SDK for [Diffgram](https://github.com/diffgram/diffgram)
and
[Diffgram.com](https://diffgram.com/)
## SDK Install
#### [Full Documentation](https://diffgram.readme.io/docs)
### Quickstart Install SDK
`pip install diffgram`
On linux
`pip3 install diffgram`
[Credentials Guide](https://diffgram.readme.io/reference)
[Get Credentials from Diffgram.com](https://diffgram.com/) (or your Private Deploy)
The starting point for most useful work is to get a project:
```
from diffgram import Project
project = Project(host = "https://diffgram.com",
project_string_id = "replace_with_project_string",
client_id = "replace_with_client_id",
client_secret = "replace_with_client_secret")
```
Replace `host` with your URL for Open Core installs.
* [Tasks Introduction](https://diffgram.readme.io/docs/tasks-introduction)
* [Import Introduction](https://diffgram.readme.io/docs/importing-your-data)
* [Updating Existing Instances](https://diffgram.readme.io/docs/importing-instances-walkthrough)
* [Pre-Label Example Video](https://youtu.be/55Hofp1H7yM)
* [Compatibility](https://diffgram.readme.io/docs/compatibility-will-diffgram-work-with-my-system)
#### Beta
Note the API/SDK is in beta and is undergoing rapid improvement. There may be breaking changes.
Please see the [API docs](https://diffgram.readme.io/reference) for the latest canonical reference
and be sure to upgrade to latest ie: `pip install diffgram --upgrade`. We will attempt to keep the SDK up to date with the API.
[Help articles for Diffgram.com](https://diffgram.readme.io/) See below for some examples.
Requires Python >=3.5
The default install through pip will install dependencies
for local prediction (tensorflow opencv) as listed in `requirements.txt`.
The only requirement needed for majority of functions is `requests`.
If you are looking for a minimal size install and already have requests use
the `--no-dependencies` flag ie `pip install diffgram --no-dependencies`
%package -n python3-diffgram
Summary: SDK for Diffgram
Provides: python-diffgram
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-diffgram
# SDK for Diffgram
This is the SDK for [Diffgram](https://github.com/diffgram/diffgram)
and
[Diffgram.com](https://diffgram.com/)
## SDK Install
#### [Full Documentation](https://diffgram.readme.io/docs)
### Quickstart Install SDK
`pip install diffgram`
On linux
`pip3 install diffgram`
[Credentials Guide](https://diffgram.readme.io/reference)
[Get Credentials from Diffgram.com](https://diffgram.com/) (or your Private Deploy)
The starting point for most useful work is to get a project:
```
from diffgram import Project
project = Project(host = "https://diffgram.com",
project_string_id = "replace_with_project_string",
client_id = "replace_with_client_id",
client_secret = "replace_with_client_secret")
```
Replace `host` with your URL for Open Core installs.
* [Tasks Introduction](https://diffgram.readme.io/docs/tasks-introduction)
* [Import Introduction](https://diffgram.readme.io/docs/importing-your-data)
* [Updating Existing Instances](https://diffgram.readme.io/docs/importing-instances-walkthrough)
* [Pre-Label Example Video](https://youtu.be/55Hofp1H7yM)
* [Compatibility](https://diffgram.readme.io/docs/compatibility-will-diffgram-work-with-my-system)
#### Beta
Note the API/SDK is in beta and is undergoing rapid improvement. There may be breaking changes.
Please see the [API docs](https://diffgram.readme.io/reference) for the latest canonical reference
and be sure to upgrade to latest ie: `pip install diffgram --upgrade`. We will attempt to keep the SDK up to date with the API.
[Help articles for Diffgram.com](https://diffgram.readme.io/) See below for some examples.
Requires Python >=3.5
The default install through pip will install dependencies
for local prediction (tensorflow opencv) as listed in `requirements.txt`.
The only requirement needed for majority of functions is `requests`.
If you are looking for a minimal size install and already have requests use
the `--no-dependencies` flag ie `pip install diffgram --no-dependencies`
%package help
Summary: Development documents and examples for diffgram
Provides: python3-diffgram-doc
%description help
# SDK for Diffgram
This is the SDK for [Diffgram](https://github.com/diffgram/diffgram)
and
[Diffgram.com](https://diffgram.com/)
## SDK Install
#### [Full Documentation](https://diffgram.readme.io/docs)
### Quickstart Install SDK
`pip install diffgram`
On linux
`pip3 install diffgram`
[Credentials Guide](https://diffgram.readme.io/reference)
[Get Credentials from Diffgram.com](https://diffgram.com/) (or your Private Deploy)
The starting point for most useful work is to get a project:
```
from diffgram import Project
project = Project(host = "https://diffgram.com",
project_string_id = "replace_with_project_string",
client_id = "replace_with_client_id",
client_secret = "replace_with_client_secret")
```
Replace `host` with your URL for Open Core installs.
* [Tasks Introduction](https://diffgram.readme.io/docs/tasks-introduction)
* [Import Introduction](https://diffgram.readme.io/docs/importing-your-data)
* [Updating Existing Instances](https://diffgram.readme.io/docs/importing-instances-walkthrough)
* [Pre-Label Example Video](https://youtu.be/55Hofp1H7yM)
* [Compatibility](https://diffgram.readme.io/docs/compatibility-will-diffgram-work-with-my-system)
#### Beta
Note the API/SDK is in beta and is undergoing rapid improvement. There may be breaking changes.
Please see the [API docs](https://diffgram.readme.io/reference) for the latest canonical reference
and be sure to upgrade to latest ie: `pip install diffgram --upgrade`. We will attempt to keep the SDK up to date with the API.
[Help articles for Diffgram.com](https://diffgram.readme.io/) See below for some examples.
Requires Python >=3.5
The default install through pip will install dependencies
for local prediction (tensorflow opencv) as listed in `requirements.txt`.
The only requirement needed for majority of functions is `requests`.
If you are looking for a minimal size install and already have requests use
the `--no-dependencies` flag ie `pip install diffgram --no-dependencies`
%prep
%autosetup -n diffgram-0.13.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-diffgram -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.13.0-1
- Package Spec generated