%global _empty_manifest_terminate_build 0
Name:		python-pysight
Version:	0.12.2
Release:	1
Summary:	Create images and volumes from photon lists generated by a multiscaler
License:	Free for non-commercial use
URL:		https://github.com/PBLab/python-pysight/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d6/b8/0ae326946d1ba89be3cd5bb4d9f59fec7d9a675ff737b48e1fa18a74313a/pysight-0.12.2.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-matplotlib
Requires:	python3-pandas
Requires:	python3-attrs
Requires:	python3-cython
Requires:	python3-scipy
Requires:	python3-scikit-learn
Requires:	python3-zarr
Requires:	python3-tqdm
Requires:	python3-numba
Requires:	python3-ansimarkup
Requires:	python3-psutil
Requires:	python3-toml
Requires:	python3-appdirs
Requires:	python3-pytest
Requires:	python3-sphinx
Requires:	python3-bumpversion
Requires:	python3-twine
Requires:	python3-black
Requires:	python3-mypy
Requires:	python3-flake8
Requires:	python3-typed-ast
Requires:	python3-pylint

%description
PySight is an application aimed at generating multidimensional imagesfrom photon lists. The main use case is to parse ``.lst`` files whichwere generated by FAST ComTec's multiscaler, but other photon listscan also be parsed.

PySight was featured in`this <https://www.osapublishing.org/optica/abstract.cfm?uri=optica-5-9-1104>`_ *Optica* article, and was created in Pablo Blinder's Lab at Tel Aviv University.



%package -n python3-pysight
Summary:	Create images and volumes from photon lists generated by a multiscaler
Provides:	python-pysight
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pysight
PySight is an application aimed at generating multidimensional imagesfrom photon lists. The main use case is to parse ``.lst`` files whichwere generated by FAST ComTec's multiscaler, but other photon listscan also be parsed.

PySight was featured in`this <https://www.osapublishing.org/optica/abstract.cfm?uri=optica-5-9-1104>`_ *Optica* article, and was created in Pablo Blinder's Lab at Tel Aviv University.



%package help
Summary:	Development documents and examples for pysight
Provides:	python3-pysight-doc
%description help
PySight is an application aimed at generating multidimensional imagesfrom photon lists. The main use case is to parse ``.lst`` files whichwere generated by FAST ComTec's multiscaler, but other photon listscan also be parsed.

PySight was featured in`this <https://www.osapublishing.org/optica/abstract.cfm?uri=optica-5-9-1104>`_ *Optica* article, and was created in Pablo Blinder's Lab at Tel Aviv University.



%prep
%autosetup -n pysight-0.12.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pysight -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.12.2-1
- Package Spec generated