%global _empty_manifest_terminate_build 0
Name: python-nmdc-schema
Version: 7.5.0
Release: 1
Summary: Schema resources for the National Microbiome Data Collaborative (NMDC)
License: MIT
URL: https://microbiomedata.github.io/nmdc-schema/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e4/d6/ba4e49d15bd09d591e6b1369e148d694afe9b9f98c54a74b1bce446d4a39/nmdc_schema-7.5.0.tar.gz
BuildArch: noarch
Requires: python3-linkml
Requires: python3-linkml-runtime
%description
# National Microbiome Data Collaborative Schema
[![PyPI - License](https://img.shields.io/pypi/l/nmdc-schema)](https://github.com/microbiomedata/nmdc-schema/blob/main/LICENSE)
[![PyPI version](https://badge.fury.io/py/nmdc-schema.svg)](https://badge.fury.io/py/nmdc-schema)
The NMDC is a multi-organizational effort to integrate microbiome data across diverse areas in medicine, agriculture,
bioenergy, and the environment. This integrated platform facilitates comprehensive discovery of and access to
multidisciplinary microbiome data in order to unlock new possibilities with microbiome data science.
This repository mainly defines a [LinkML](https://github.com/linkml/linkml) schema for managing metadata from
the [National Microbiome Data Collaborative (NMDC)](https://microbiomedata.org/).
## Repository Contents Overview
Some products that are maintained, and tasks orchestrated within this repository are:
- Maintenance of LinkML YAML that specifies the NMDC Schema
- [src/schema/nmdc.yaml](src/schema/nmdc.yaml)
- and various other YAML schemas imported by it,
like [prov.yaml](src/schema/prov.yaml), [annotation.yaml](src/schema/annotation.yaml), etc. all which you can find
in the [src/schema](src/schema/) folder
- Makefile targets for converting the schema from it's native LinkML YAML format to other artifact
like [JSON Schema](project/jsonschema/nmdc.schema.json)
- Build, deployment and distribution of the schema as a PyPI package
- Automatic publishing of refreshed documentation upon change to the schema,
accessible [here](https://microbiomedata.github.io/nmdc-schema/)
## Background
The NMDC [Introduction to metadata and ontologies](https://microbiomedata.org/introduction-to-metadata-and-ontologies/)
primer provides some the context for this project.
## Maintaining the Schema
**New system requirement: [Mike Farah's GO-based yq](https://github.com/mikefarah/yq)**
See [MAINTAINERS.md](MAINTAINERS.md) for instructions on maintaining and updating the schema.
%package -n python3-nmdc-schema
Summary: Schema resources for the National Microbiome Data Collaborative (NMDC)
Provides: python-nmdc-schema
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-nmdc-schema
# National Microbiome Data Collaborative Schema
[![PyPI - License](https://img.shields.io/pypi/l/nmdc-schema)](https://github.com/microbiomedata/nmdc-schema/blob/main/LICENSE)
[![PyPI version](https://badge.fury.io/py/nmdc-schema.svg)](https://badge.fury.io/py/nmdc-schema)
The NMDC is a multi-organizational effort to integrate microbiome data across diverse areas in medicine, agriculture,
bioenergy, and the environment. This integrated platform facilitates comprehensive discovery of and access to
multidisciplinary microbiome data in order to unlock new possibilities with microbiome data science.
This repository mainly defines a [LinkML](https://github.com/linkml/linkml) schema for managing metadata from
the [National Microbiome Data Collaborative (NMDC)](https://microbiomedata.org/).
## Repository Contents Overview
Some products that are maintained, and tasks orchestrated within this repository are:
- Maintenance of LinkML YAML that specifies the NMDC Schema
- [src/schema/nmdc.yaml](src/schema/nmdc.yaml)
- and various other YAML schemas imported by it,
like [prov.yaml](src/schema/prov.yaml), [annotation.yaml](src/schema/annotation.yaml), etc. all which you can find
in the [src/schema](src/schema/) folder
- Makefile targets for converting the schema from it's native LinkML YAML format to other artifact
like [JSON Schema](project/jsonschema/nmdc.schema.json)
- Build, deployment and distribution of the schema as a PyPI package
- Automatic publishing of refreshed documentation upon change to the schema,
accessible [here](https://microbiomedata.github.io/nmdc-schema/)
## Background
The NMDC [Introduction to metadata and ontologies](https://microbiomedata.org/introduction-to-metadata-and-ontologies/)
primer provides some the context for this project.
## Maintaining the Schema
**New system requirement: [Mike Farah's GO-based yq](https://github.com/mikefarah/yq)**
See [MAINTAINERS.md](MAINTAINERS.md) for instructions on maintaining and updating the schema.
%package help
Summary: Development documents and examples for nmdc-schema
Provides: python3-nmdc-schema-doc
%description help
# National Microbiome Data Collaborative Schema
[![PyPI - License](https://img.shields.io/pypi/l/nmdc-schema)](https://github.com/microbiomedata/nmdc-schema/blob/main/LICENSE)
[![PyPI version](https://badge.fury.io/py/nmdc-schema.svg)](https://badge.fury.io/py/nmdc-schema)
The NMDC is a multi-organizational effort to integrate microbiome data across diverse areas in medicine, agriculture,
bioenergy, and the environment. This integrated platform facilitates comprehensive discovery of and access to
multidisciplinary microbiome data in order to unlock new possibilities with microbiome data science.
This repository mainly defines a [LinkML](https://github.com/linkml/linkml) schema for managing metadata from
the [National Microbiome Data Collaborative (NMDC)](https://microbiomedata.org/).
## Repository Contents Overview
Some products that are maintained, and tasks orchestrated within this repository are:
- Maintenance of LinkML YAML that specifies the NMDC Schema
- [src/schema/nmdc.yaml](src/schema/nmdc.yaml)
- and various other YAML schemas imported by it,
like [prov.yaml](src/schema/prov.yaml), [annotation.yaml](src/schema/annotation.yaml), etc. all which you can find
in the [src/schema](src/schema/) folder
- Makefile targets for converting the schema from it's native LinkML YAML format to other artifact
like [JSON Schema](project/jsonschema/nmdc.schema.json)
- Build, deployment and distribution of the schema as a PyPI package
- Automatic publishing of refreshed documentation upon change to the schema,
accessible [here](https://microbiomedata.github.io/nmdc-schema/)
## Background
The NMDC [Introduction to metadata and ontologies](https://microbiomedata.org/introduction-to-metadata-and-ontologies/)
primer provides some the context for this project.
## Maintaining the Schema
**New system requirement: [Mike Farah's GO-based yq](https://github.com/mikefarah/yq)**
See [MAINTAINERS.md](MAINTAINERS.md) for instructions on maintaining and updating the schema.
%prep
%autosetup -n nmdc-schema-7.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-nmdc-schema -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 7.5.0-1
- Package Spec generated